Forum

Developer Preview 18.05

23 May 2018 22:14
Developer Preview 18.05 is available for registered users: https://www.blend4web.com/en/downloads/. NPM-package: https://www.npmjs.com/package/blend4web
New features - new webplayer, basic support for refraction in PBR pipeline and more!
Alexander (Blend4Web Team)
twitter
24 May 2018 12:08
Hi,

Not sure if this is the appropriate place to report feedback for the Developer Preview 18.05 release. Nonetheless, when clicking on the "Fast Preview" button (with the default scene/cube), an overlay is displayed with some Python (connection) errors being reported (see attached screen). This is with macOS High Sierra (10.13.4) and Blender 2.79b. Let me know if you need any additional details.
28 May 2018 10:11
I’ve tested the new release and it seems to work properly. Is there any new example-project in mind?
31 May 2018 23:04
I noticed the animation slowed down, losing frames when the lower menu appeared in the new b4w player

Windows 7 64bit, InteI I3-4330, 8GB ram, Geforce GTS 450
07 June 2018 03:15
I'm confused as to where to get the new build. It's not showing on the Downloads page unless this is strictly for the $1000 club.
07 June 2018 19:53
Hallo Blend4web team!

I'm having the same issue than Brett Kromkamp. I have same platform and blender version: macOS High Sierra (10.13.4) and Blender 2.79.

In the Development tools buttons "SDK index" and "project manager" don't work. It seems to work only "stop server" and "start server". So I can't access the project manager.

I have updated Python to 3.6.2. Maybe I'm still missing some library?
The problem remains with the official release. With previous releases I had no problem.
I have attached a txt file reporting error from mac terminal.
Please help!
Blend4web rocks!
10 June 2018 22:53
Hi b4w team,

Have the same issue on my Mac, that mazzilla is describing.
13 June 2018 12:39
Thank you all for the reports. Will check this.
Alexander (Blend4Web Team)
twitter
13 June 2018 19:17
Alexander, please see my attached image in the Forum's Bug section. It's the same problem described above by other Mac users. The image probably has useful information to determine which is the source of this error.
Best Regards
15 June 2018 15:17
To solve this issue please use this patch :
1. Copy attached file to the SDK folder
2. Open the Terminal (or any other console you like to use)
3. Go to the folder with SDK using Terminal(console)
4. Apply the patch using this command
patch scripts/find_nodejs.py < fixOS.patch

Alternative way to fix this problem:
1. Open the folder with SDK and find the file find_nodejs.py in Scripts folder
2. Open find_nodejs.py with any text editor
3. Move the line import lzma fron line 5 to line 85 (between if dist.endswith("tar.xz"): and with lzma.open(dist) as f:) . Resulting piece shold look like this

Be careful with indent in the code
Ekaterina (Blend4Web Team)
 
Please register or log in to leave a reply.