Forum

Audio Speed

16 August 2018 14:15
Hello and thanx for the marvelous product in blend4web. I'm developing a proof of concept for a website I'm developing and am having trouble with the positional sound object. When i move the camera towards the sound it speeds up the playback. The goal is to have users navigate the site by lights and sound. Getting closer to an object should make the song clearer but it, instead, puts it at chipmunk speed until the track loops around. Is there a solution or common workaround?
16 August 2018 19:22
Do you have "Doppler" deactivated on the speaker object? Also, there is this:
listener_stride()

Make a listener stride. Use before quick listener movements to neutralize undesirable doppler effect.
17 August 2018 19:08
I am also making an audio device for my car and I want to make it look more style with substances. The audio device will have a light panel which will go off and on when the volume will rise or go down. For Printer repair Dubai I have also made a similar device for their project.
17 August 2018 22:54
Reply to post of user Blend4Life
Do you have "Doppler" deactivated on the speaker object? Also, there is this:
I'm gonna try this as soon as i get off of work
21 August 2018 00:48
It certainly did help. Thanx.

Reply to post of user Blend4Life
Do you have "Doppler" deactivated on the speaker object? Also, there is this:

And I'll be looking into the listener_stride() function soon as I get this proof of concept up and running. Thanx again.
 
Please register or log in to leave a reply.