Blend4Web player freezed in smartphones with GPU MALI-T830/880

26 September 2018 01:03
Hi Blend4We team!! first of all congrats for this powerful software!!!

I started learning developing 3D with the API a couple of months ago, testing in my Samsung J5 2016 device and everything works like a charm, I also test it in devices prior to 2017 and all worked smoothly… but my issue was that when testing in new devices, most show the 3D model in the WebGl player but cannot interact with it, even tested the player provided from the API projects manager with same results. Model is just freezed and clicking buttons to rotate or trying to zoom in/out won't work.

I have tested in a Smartphone store almost 20 different models and only 2 seem to work correctly (very weird behavior), so started to search many parameters and found out maybe the problem? smartphones with GPU's MALI-T8XX are not working, and Ardeno's are working perfectly.

Some tested models:
Samsung Galaxy A6 -> MALI-T830 not working
Samsung Galaxy A6 plus -> Ardeno 306 working

Samsung Galaxy J5 2017 -> MALI-T830 not working
Samsung Galaxy J5 2016 -> Ardeno 506 working

Samsung Galaxy J7 2017 -> MALI-T880 not working
Samsung Galaxy S7 -> MALI-T830 not working
Huawei P20 Lite -> MALI-T830 not working

HTC u11 -> Ardeno 540 -> working
iPhone 5, 6 and 7 -> working

If you want to reproduce this behavior just test the excellent code snippets page from a MALI-T830, MALI-T880 GPU, only the first sample may work (Bone API), the rest will freeze or behave strange: For example the Custom anchors will only rotate the anchors, not the objects.

My blender version is 2.79b
My blend4Web version is 18.05.0 SDK

If you need more information, testings or videos showing better the issue please let me know.

Looking forward for any comments!

Thanks in advance!
03 December 2018 17:34
Hi again community!

Just to let you know in case someone is facing the same problem (which seems I am the only one ) … I found after making hundreds of tests that if I add to the init method the Quality and the msaa_samples:

quality: m_cfg.P_CUSTOM,
msaa_samples: 1

The model works in all devices again!! even in all the MALI GPU's I listed a couple of months ago…
I found this solution thanks to an older thread of this forum (

Hope this help to newbies as me to NOT frustrate yourselves!!! There is always light at the end of the tunnel,
I don't really know why, but after adding those two lines, the models worked like a charm.

Please register or log in to leave a reply.