Forum

PBR not working

17 December 2018 06:22
Hey there I'm having to work from home (thanks broken knee cap), and blend4web files that worked at work aren't displaying correctly when I export a html file from Blender (ie the materials display as purple).

Even when I start a new file in Blender 2.79b and add a Principled BSDF material and export that on a cube it's still showing up as purple (and I haven't even added textures yet).

See example file here…

http://pasteall.org/blend/index.php?id=50915

Can anyone help me why this is happening?
17 December 2018 09:07
I tried a laptop and that worked so what would my machine be mucking up?

I have a desktop win10, GeForce GTX 970 x2, i7-5820k with 50Gb free space on HD.
17 December 2018 22:49
Generally, purple always means missing texture (missing image file). Look at the console when you run the scene. It will tell you which files are missing. All the files of a project have to be present in the correct paths given. Are you maybe using a .blend with packed files? I don't think you can just export the scene as is, you need to unpack and provide the textures to the scene.

BTW, the world texture in the upload link is unsupported (cannot use .hdr).
18 December 2018 01:01
Thanks for that Blend4Life,

I understand that purple means a missing texture, but I have no textures connected to the PBR material.



And I tried again disconnecting the hdr background



and when you say console do you mean Chrome's



or Blender's



or do you mean Blend4web's "Strict Mode"



because I'm not sure what's going on based off those screenshots because I'm using Blender 2.79b (tried both off blender.org and from the blend4web site) and I thought the PBR node was supported (well I know it is because it works on my work machine and laptop but for some reason not on my home desktop)

Any help is appreciated.
18 December 2018 01:24
Yes, I meant the browser console. I'm definitely not getting

"The Principled… is not supported"

on B4W v18.05 with your file. Are you sure you're using that version (the latest version) on the machine that put out these messages?

(You should run 17.12 or 18.05 for PBR.)
18 December 2018 01:28
Ok finally worked it out.

Looks like when I download Blender 2.79b it only has blend4web version 17.4.1 so I had to re-download the latest version, ie 18.05.0 and now it's working.

Man what a pain :(

Thanks for your help anyhow.
 
Please register or log in to leave a reply.