Форум

Не могу создать проект

13 мая 2016 11:27 #9477
До этого баловался только экспортом из блендера, а тут решил создать проект с нуля по правилам. И ничего не получается.

Из Блендера Открываю SDK - Менеджер проектов - Create new project - заполняю, не важно как, - Create Project Вываливается ошибка:
Traceback (most recent call last):
File "/home/kostia/Bin/blend4web_sdk_free/apps_dev/project.py", line 43, in
import project_cli
File "/home/kostia/Bin/blend4web_sdk_free/scripts/lib/project_cli.py", line 327
print(" " + "-"*(len(err)), file=sys.stderr)
^
SyntaxError: invalid syntax


Открыл SDK в файловом менеджере, зашёл в /apps_dev, набрал команду ./project.py init -ASBP -C liolik -T superuberpupergame superuberpupergame - теперь вываливается с такой ошибкой:
Creating a new bundled up project

Name: superuberpupergame
Title: superuberpupergame
Author (Company): liolik

Creating directory for source files: apps_dev/superuberpupergame
Creating project settings file: apps_dev/superuberpupergame/.b4w_project
Copying project.py script into project directory:
apps_dev/superuberpupergame/project.py
Copying application template files into destination directories:
apps_dev/superuberpupergame/superuberpupergame.html
apps_dev/superuberpupergame/superuberpupergame.js
apps_dev/superuberpupergame/superuberpupergame.css
Compilation Finished
Copying scene template files into destination directories:
apps_dev/superuberpupergame/superuberpupergame.blend
exporting apps_dev/superuberpupergame/superuberpupergame.blend
apps_dev/superuberpupergame/superuberpupergame
Traceback (most recent call last):
File "/usr/share/blender/2.77/scripts/modules/addon_utils.py", line 349, in enable
mod.register()
File "/usr/share/blender/2.77/scripts/addons_contrib/sequencer_extra_actions/__init__.py", line 64, in register
km = kc.keymaps.new(name='Frames')
AttributeError: 'NoneType' object has no attribute 'keymaps'
Traceback (most recent call last):
File "/usr/share/blender/2.77/scripts/modules/addon_utils.py", line 330, in enable
mod = __import__(module_name)
File "/home/kostia/.config/blender/2.77/scripts/addons/io_import_georaster.py", line 42, in <module>
import numpy as np#Ship with Blender since 2.70
File "/usr/lib/python3/dist-packages/numpy/__init__.py", line 153, in <module>
from . import add_newdocs
File "/usr/lib/python3/dist-packages/numpy/add_newdocs.py", line 13, in <module>
from numpy.lib import add_newdoc
File "/usr/lib/python3/dist-packages/numpy/lib/__init__.py", line 8, in <module>
from .type_check import *
File "/usr/lib/python3/dist-packages/numpy/lib/type_check.py", line 11, in <module>
import numpy.core.numeric as _nx
File "/usr/lib/python3/dist-packages/numpy/core/__init__.py", line 6, in <module>
from . import multiarray
ImportError: cannot import name 'multiarray'
Traceback (most recent call last):
File "/home/kostia/Bin/blend4web_sdk_free/addons/blend4web/update_checker.py", line 69, in check_for_update_callback
new_ver = check_for_update(blender_current_version, b4w_current_version)
File "/home/kostia/Bin/blend4web_sdk_free/addons/blend4web/update_checker.py", line 31, in check_for_update
r = urllib.request.urlopen('https://www.blend4web.com/get_versions/', timeout=1).readall()
AttributeError: 'HTTPResponse' object has no attribute 'readall'


Искал по сайту, не нашёл таких проблем. Я один такой? Я настолько криворук, что у меня не работает то, что у всех работает? Или просто никто так не делает, а копирует всё ручками?

П. С. у меня Линукс, Убунту 14.04.
13 мая 2016 15:40 #9481
Возможно проблема в том, что вместо python 3 вызывается python 2. Какую сборку Blender вы используете? Откуда качали? Наберите команду bpy.app.binary_path_python в консоли Blender. Должен вывестись путь к исполняемому файлу python из дистрибутива Blender.
Александр (команда Blend4Web)
14 мая 2016 08:29 #9492
bpy.app.binary_path_python говорит /usr/bin/python

Blender из этого PPA

В системе установлен numpy и второго и третьего Питона, притащили другие приложения. По зависимостям, вроде, Блендер требует 3 Питон и рекомендует 3 numpy. Блендер 100% рабочий и никаких ошибок не наблюдается. Но /usr/bin/python - действительно выдаёт версию 2.7 И как это понять?

Кстати, я не написал, я пробовал запускать менеджер проектов в консоли с третьим питоном, та же история.
14 мая 2016 15:56 #9500
PPA - считай кастомная сборка. Это баг сборки, если упомянутая переменная ссылается на системный питон. Скачайте Blender с официального сайта. Официальная сборка содержит в себе исполняемый файл питона и остальные библиотеки, в том числе и numpy.
Александр (команда Blend4Web)
16 мая 2016 13:59 #9547
Да, пришлось не только скачать новый, но и удалить старый, так как всё равно не работало. Спасибо за помощь.
 
Пожалуйста, зарегистрируйтесь или войдите под своей учетной записью , чтобы оставлять сообщения.