Форум

Плак-плак Файрфокс

28 мая 2016 16:42 #9765
Дорогие разработчики. Плачуся вам. Замучался, чесслово. Три дня бился над тенями/шейдерами, не показывает в экспорте и просмотрщике теней и всё тут, собирался уже багу оформлять… Пока не дошло посмотреть в другом браузере. И о чудо! Тени оказались на месте, это мой фокс мозги полировал. ТРИ ДНЯ!!! Дальнейшее расследование показало, что он не показывает и отражений и постпроцессинга. (ВОТ корень того, что вода в пандах у меня не зеркальная, я не понял тогда как её настроить, потому что тупо не работало в фоксе)

Попробовал создать новый профиль в фоксе, заработало. Начал сравнивать, в чём разница между старым и новым, не нашёл, ни в about:config и нигде. Как воспроизвести не знаю, тупо не работает в старом профиле. Как теперь сообщить им, этим?

Я бы плюнул и работал в той же Qupzilla, но я же не могу сказать людям, что "это у вас браузер не правильный, поэтому мою кроссплатформенную красоту некрасиво показывает!", ведь это тень на ваш (не побоюсь этого слова) великолепный движок, который тут не при чём! Кто его знает, как у заказчика/клиента/зеваки всё показывать будет? Никакой гарантии, что после падения фокс чего-то не отключит навсегда и будет тупо показывать ерунду.

Выдохнул. Вы уж извините, что моё ЖЖ тут.
30 мая 2016 10:58 #9772
Фокс часто тупит. Мы уже ругались много разрабам лисы, они там что-то свое мутят и делают так, что WebGL работает только хуже и хуже. Я лично не знаю, с чем это связано, может более знающий народ подскажет, но, к сожалению, мне самому приходится к своим работам писать "Recommended to watch in Chrome", хотя в общем и целом мне лиса нравится больше.
3D Художник (Generalist), администратор конкурсов,
команда Blend4Web
арт блог: http://contret-art.tumblr.com/
30 мая 2016 13:57 #9776
Добрый день.
Попробуйте сравнить результаты теста http://webglreport.com/ для двух браузеров
Разработчик Blend4Web
30 мая 2016 14:41 #9777
не показывает в экспорте и просмотрщике теней
а если смотреть во вьюере по Fast Export, то в консоли браузера никаких ошибок/сообщений нет?
Команда Blend4Web
30 мая 2016 15:11 #9779
Ой, забыл написать, отчёты http://webglreport.com/ идентичны. WEBGL_depth_texture присутствует.
WEBGL 2.0 отключен на обоих профилях (это фокс сам, я настроек не трогал)

В консоли в старом профиле теперь вообще мою сцену не показывает :) Чойта накрутил уже, хотя, я же ничего не трогал, только переименовывал папку .mozilla Вот вывод консоли когда открываю быстрый просмотр в сломаном профиле:
B4W LOG: INIT ENGINE 16.05 DEBUG (30.05.2016 15:02:31) print.js:50:9
Error: WebGL: Error during native OpenGL init. main.js:221:19
Error: WebGL: WebGL creation failed. main.js:221:19
B4W LOG: INIT WEBGL 1 print.js:50:9
B4W LOG: GET EXTENSION WEBGL_debug_renderer_info print.js:50:9
B4W LOG: INIT WEBAUDIO: 48000Hz print.js:50:9
B4W LOG: GET EXTENSION WEBGL_depth_texture print.js:50:9
B4W LOG: GET EXTENSION WEBGL_compressed_texture_s3tc print.js:50:9
B4W LOG: SET PRECISION: mediump print.js:50:9
B4W LOG: LOAD METADATA ../../tmp/preview.json?t=30052016150232 print.js:50:9
B4W LOG: LOAD BINARY ../../tmp/preview.bin?t=30052016150232 print.js:50:9
B4W WARN: negative scale for object "KameraNaUlicu", can lead to some errors print.js:112:5
B4W WARN: non-uniform scale for object KameraNaUlicu print.js:112:5
B4W LOG: GET EXTENSION OES_standard_derivatives print.js:50:9
B4W LOG: PHYSICS READY print.js:50:9
B4W LOG: LOAD IMAGE 1024x1024 ../../apps_dev/Kolobok/Tex/Okr/voda-norm.png?t=30052016150233 print.js:50:9
B4W LOG: LOAD IMAGE 2048x2048 ../../apps_dev/Kolobok/Tex/kist.png?t=30052016150233 print.js:50:9
B4W LOG: LOAD IMAGE 1024x1024 ../../apps_dev/Kolobok/Tex/Kniga.png?t=30052016150233 print.js:50:9
B4W LOG: LOAD IMAGE 2048x2048 ../../apps_dev/Kolobok/Tex/Dev/Dev.Volosy-Cvet.png?t=30052016150233 print.js:50:9
B4W LOG: LOAD IMAGE 2048x2048 ../../apps_dev/Kolobok/Tex/Dev/Dev.Lico-cvet.png?t=30052016150233 print.js:50:9
B4W LOG: LOAD IMAGE 1024x1024 ../../apps_dev/Kolobok/Tex/Dev/Pijama.png?t=30052016150233 print.js:50:9
B4W LOG: LOADED ALL IMAGES print.js:50:9
B4W LOG: LOAD SOUND ../../apps_dev/Kolobok/Zvukezz/Komnata.ogg?t=30052016150238 print.js:50:9
B4W LOG: LOAD SOUND ../../apps_dev/Kolobok/Zvukezz/Noc.ogg?t=30052016150238 print.js:50:9
B4W LOG: LOADED ALL SOUNDS print.js:50:9
uncaught exception: No aspect ratio <неизвестно>
Error: WebGL: drawElements: Drawing to a destination rect smaller than the viewport rect. (This warning will only be given once) renderer.js:511:9
uncaught exception: No aspect ratio <неизвестно>
B4W LOG: START NLA print.js:50:9
uncaught exception: No aspect ratio <неизвестно>

В новом такой выхлоп:
B4W LOG: GET EXTENSION OES_standard_derivatives print.js:50:9
B4W LOG: INIT ENGINE 16.05 DEBUG (30.05.2016 15:10:40) print.js:50:9
B4W LOG: INIT WEBGL 1 print.js:50:9
B4W LOG: GET EXTENSION WEBGL_debug_renderer_info print.js:50:9
B4W LOG: INIT WEBAUDIO: 48000Hz print.js:50:9
B4W LOG: GET EXTENSION WEBGL_depth_texture print.js:50:9
B4W LOG: GET EXTENSION WEBGL_compressed_texture_s3tc print.js:50:9
B4W LOG: SET PRECISION: highp print.js:50:9
B4W LOG: LOAD METADATA ../../tmp/preview.json?t=30052016151041 print.js:50:9
B4W LOG: LOAD BINARY ../../tmp/preview.bin?t=30052016151041 print.js:50:9
B4W WARN: negative scale for object "KameraNaUlicu", can lead to some errors print.js:112:5
B4W WARN: non-uniform scale for object KameraNaUlicu print.js:112:5
B4W LOG: GET EXTENSION OES_standard_derivatives print.js:50:9
B4W LOG: PHYSICS READY print.js:50:9
B4W LOG: LOAD IMAGE 1024x1024 ../../apps_dev/Kolobok/Tex/Okr/voda-norm.png?t=30052016151043 print.js:50:9
B4W LOG: LOAD IMAGE 1024x1024 ../../apps_dev/Kolobok/Tex/Kniga.png?t=30052016151043 print.js:50:9
B4W LOG: LOAD IMAGE 2048x2048 ../../apps_dev/Kolobok/Tex/Dev/Dev.Volosy-Cvet.png?t=30052016151043 print.js:50:9
B4W LOG: LOAD IMAGE 2048x2048 ../../apps_dev/Kolobok/Tex/Dev/Dev.Lico-cvet.png?t=30052016151043 print.js:50:9
B4W LOG: LOAD IMAGE 1024x1024 ../../apps_dev/Kolobok/Tex/Dev/Pijama.png?t=30052016151043 print.js:50:9
B4W LOG: LOAD IMAGE 2048x2048 ../../apps_dev/Kolobok/Tex/kist.png?t=30052016151043 print.js:50:9
B4W LOG: LOADED ALL IMAGES print.js:50:9
Error: WebGL: drawElements: Active texture 0 for target 0x0de1 is uninitialized, and will be (perhaps slowly) cleared by the implementation. renderer.js:511:9
Error: WebGL: drawElements: This operation requires zeroing texture data. This is slow. renderer.js:511:9
B4W LOG: LOAD SOUND ../../apps_dev/Kolobok/Zvukezz/Komnata.ogg?t=30052016151049 print.js:50:9
B4W LOG: LOAD SOUND ../../apps_dev/Kolobok/Zvukezz/Noc.ogg?t=30052016151049 print.js:50:9
B4W LOG: LOADED ALL SOUNDS print.js:50:9
B4W LOG: THREAD 0: LOADED CALLBACK print.js:50:9
B4W LOG: START NLA
30 мая 2016 15:18 #9780
Error during native OpenGL init
по этой ошибке гуглится вот такое решение:
ссылка

вроде, в about:support должна быть какая-то информация об ошибке, там же можно будет и сбросить настройки
Команда Blend4Web
30 мая 2016 17:31 #9789
Нет, очевидно в старом профиле что-то меняется, определённо становится хуже, без моего участия. Я не изменял проект, после того как понял, что что-то не так, просто отложил, настройки Фокса тоже не менял. Но! Теперь Фокс (в старом профиле) не показывает вообще никаких сцен. главное, меню блендфовебовское есть, а сцен нет. Просто серый квадрат, причём оно там, за ним, шевелится и реагирует на мои действия. И так с любым webgl.
 
Пожалуйста, зарегистрируйтесь или войдите под своей учетной записью , чтобы оставлять сообщения.