Форум

Странное поведение Project Manager'а при первом билде

05 апреля 2017 17:59
Сразу после создания проекта, если нажать Build, то помимо того, что проект соберется, ещё появится непонятная ссылка в менеджере:



Которая на самом деле ведёт на билд версию (вторая уже ведёт на дев и третья ведёт, как написано, на билд).
https://puzzlehome.pro/
06 апреля 2017 17:52
Какой версии у вас blender и blend4web?
06 апреля 2017 18:49
Нашли ошибку; воспроизводится в Windows.
Можно заменить 605 строку:

if not str(html).startswith(join(root, build_dir, "build"))]
на
if not str(html).startswith(normpath(join(root, build_dir, "build")))]
06 апреля 2017 19:16
Ответ на сообщение пользователя Дмитрий Жиганов
Какой версии у вас blender и blend4web?
Версии свеженькие, недельной давности были)


Ответ на сообщение пользователя Дмитрий Жиганов
Можно заменить 605 строку

А можно ли уже в готовом проекте удалить эту первую строку?
Или эти правки сами всё исправят?

И если вносить правки в 605 строке, то в каком файле?
https://puzzlehome.pro/
07 апреля 2017 09:40
Файл - project_server.py. Все должно заработать.
07 апреля 2017 13:59
Не помогло. Может это для новых проектов уже будет работать, но старый проект с лишней строчкой на dev: это не исправило:

https://puzzlehome.pro/
07 апреля 2017 14:14
Не помогло. Может это для новых проектов уже будет работать
Новый или старый здесь ни при чём.

Попробуйте перезапустить blender.
Если не помогло - откройте python console в самом blender и посмотрите версию python.
Там будет что-то вроде PYTHON INTERACTIVE CONSOLE 3.5.2.
07 апреля 2017 16:43
Ну конечно я перезапускал.

PYTHON INTERACTIVE CONSOLE 3.5.2 (default, Dec  1 2016, 20:58:16) [MSC v.1800 64 bit (AMD64)]


Всё также.
https://puzzlehome.pro/
07 апреля 2017 17:47
Всё также.

Не получилось воспроизвести.
Не могли бы вы прикрепить проект?
07 апреля 2017 18:03
Дак у меня на любом проекте так. Тупо самом новом даже.
Т.е. создаю новый проект через PM, и в окне с проектами сразу нажимаю build…

Есть один нормально рабочий проект, в котором нет этой проблемы, и только потому, что я вручную установил там Apps в конфиге (тестил, кстати в документации написано, что там можно писать название только, но по факту нужно ещё и .html добавлять)



Ну и проект (проблемный) в аттаче
https://puzzlehome.pro/
 
Пожалуйста, зарегистрируйтесь или войдите под своей учетной записью , чтобы оставлять сообщения.