Форум

Неправильный экспорт в HTML

20 мая 2015 22:52 #2448
Здравствуйте.
Сегодня первый раз попробовал воспользоваться проектом blend4web который неоднократно мелькал в группе в http://vk.com/blender_3d
Спасибо, что создали его.

Проблема в следующем:
Скачал плагин, установил, все по инструкции, хоть это и обыденное дело.
После экспорта в HTML и запуска в яндекс браузере я увидел серый экран.

Зашел в раздел ошибок. Обновил все что было описано, проверил настройки браузера about. Все должно работать. Тестовая страница запускается. Примеры с сайта тоже запускаются.
Установил мозилу, включил в конфиге webgl.force…. но к сожалению тоже увидел серый экран.
Подумав, что может тупят 3 разные видео карты которые у меня установлены пошел проверять этот файл уже на ноутбуке.
И несколько раз менял сцену, мало ли косячно экспорт произвелся.
Но все безрезультатно.

В общем зашел в Linux mint 17.1 сделал тот же экспорт того же файла и о счастье все заработало. Причем заработал новый файл и в виндовс.

Блендер использовался steam версия в обеих системах 2.74, аддон с сайта 15.04 по первой ссылке с поддержкой 2.74 так же в обеих системах.

Но почему то экспорты в виндовс не дают результаты, а экспорты сделанные в линукс работают под всем что можно.

Извините за такое долгое раглагольство =)
Baasis - vk.com/baasis - vk.com/pro_blender
OS: Mint 18 Sarah x86_64 Linux 4.4.0-21-generic, DE Cinnamon, CPU: Intel Core i7-2600K CPU @ 6.3GHz, GPU: GeForce GTX 680, GeForce GTX 650 Ti, RAM 16Gb
Браузеры: неадекватный FireFox v49, не люблю но тестирую все на Google Chrome v54, вроде сойдет Vivaldi 1.4.589.38
21 мая 2015 09:51 #2449
Добрый день и добро пожаловать на форум.

После экспорта в HTML и запуска в яндекс браузере я увидел серый экран.

Но почему то экспорты в виндовс не дают результаты

Не могли бы вы подробнее описать используемую вами операционную систему?
Разработчик Blend4Web
22 мая 2015 08:42 #2458
OS windows 7 professional 64bit
6.1.7601.17727 (Win7 RTM)
Service Pack 1
steam в нем Blender 2.74
аддон со страницы загрузки
После экспорта у файла есть размер, но содержимое не запускается, даже загрузки нет.
Baasis - vk.com/baasis - vk.com/pro_blender
OS: Mint 18 Sarah x86_64 Linux 4.4.0-21-generic, DE Cinnamon, CPU: Intel Core i7-2600K CPU @ 6.3GHz, GPU: GeForce GTX 680, GeForce GTX 650 Ti, RAM 16Gb
Браузеры: неадекватный FireFox v49, не люблю но тестирую все на Google Chrome v54, вроде сойдет Vivaldi 1.4.589.38
22 мая 2015 11:47 #2460
Здравствуйте.
Мы протестировали на подобной системе наш аддон, но воспроизвести проблему пока не удалось.
Хорошо бы иметь возможность сравнить результаты удачного и неудачного экспорта одной и той же сцены. Не могли бы вы выложить соответствующие html? Ну и blend файл, если это не стандартная стартовая сцена blender.
Александр (команда Blend4Web)
25 мая 2015 09:41 #2486
По видимому у меня какой то глюк был.
Не очень понял закономерность, но…
Решил установить SDK. Указал папку скриптов, предварительно удалив Blend4web.
Перезапустил блендер. Заработал экспортер, но sdk не заработало, а именно не появилось окошко preferens в меню включения аддона blend4web.
В итоге удалил все. Скачал снова. Вроде все появилось и запустилось.
А неисправный файл я удалил к сожалению уже.
Наверное и вопрос мой можно удалить =)
т.к. что то непонятное произошло и так же непонятно и разрешилось.
Baasis - vk.com/baasis - vk.com/pro_blender
OS: Mint 18 Sarah x86_64 Linux 4.4.0-21-generic, DE Cinnamon, CPU: Intel Core i7-2600K CPU @ 6.3GHz, GPU: GeForce GTX 680, GeForce GTX 650 Ti, RAM 16Gb
Браузеры: неадекватный FireFox v49, не люблю но тестирую все на Google Chrome v54, вроде сойдет Vivaldi 1.4.589.38
26 мая 2015 00:08 #2493
Новая проблема неправильного экспорта.
Текстуры нивкакую не хотят адекватно себя вести.
Причем изменение настроек или замена текстуры не спасает.
Baasis - vk.com/baasis - vk.com/pro_blender
OS: Mint 18 Sarah x86_64 Linux 4.4.0-21-generic, DE Cinnamon, CPU: Intel Core i7-2600K CPU @ 6.3GHz, GPU: GeForce GTX 680, GeForce GTX 650 Ti, RAM 16Gb
Браузеры: неадекватный FireFox v49, не люблю но тестирую все на Google Chrome v54, вроде сойдет Vivaldi 1.4.589.38
26 мая 2015 02:08 #2496
Похожая проблема возникает, когда используются NPOT-текстуры - т.е. с размерами не в степени двойки.

Текстуру, кажется, узнаю - cgtextures? Если да, то там, вроде, все как раз NPOT: 640х640, 1600х1600 и т.д. :)
Попробуйте сжать до 512х512 или расширить до 1024х1024 - вполне возможно, это поможет.
3D Художник (Generalist), администратор конкурсов,
команда Blend4Web
арт блог: http://contret-art.tumblr.com/
27 мая 2015 01:41 #2523
Большое спасибо. Помогло
Не обратил должного внимания на документацию.

Интересно почему некоторые материалы нормально кушают нестандартные текстуры.
И почему такое странно ограничение?

Да CGtexture они везде узнаются =)
Baasis - vk.com/baasis - vk.com/pro_blender
OS: Mint 18 Sarah x86_64 Linux 4.4.0-21-generic, DE Cinnamon, CPU: Intel Core i7-2600K CPU @ 6.3GHz, GPU: GeForce GTX 680, GeForce GTX 650 Ti, RAM 16Gb
Браузеры: неадекватный FireFox v49, не люблю но тестирую все на Google Chrome v54, вроде сойдет Vivaldi 1.4.589.38
27 мая 2015 11:01 #2527
Это ограничение самого WebGL, вроде как, связано с оптимизацией

NPOT - текестуры накладываются единожды, а затем растягиваются в бесконечность. То есть, если повезет, этого видно не будет - например, если картинка просто 1-в-1 лежит на плейне. Однако если ее масштабировать или, что еще страшнее, положить на кубик, у которого UV-развертка выходит за область картинки - то результат будет вот таким

npot.blend
3D Художник (Generalist), администратор конкурсов,
команда Blend4Web
арт блог: http://contret-art.tumblr.com/
21 сентября 2015 14:24 #3975

Ответ на сообщение пользователя Александр Романов
Здравствуйте.
Мы протестировали на подобной системе наш аддон, но воспроизвести проблему пока не удалось.
Хорошо бы иметь возможность сравнить результаты удачного и неудачного экспорта одной и той же сцены. Не могли бы вы выложить соответствующие html? Ну и blend файл, если это не стандартная стартовая сцена blender.

В очередной раз повторилась проблема и не могу ее исправить. В прошлый раз магическим образом исправилось все после переустановки плагина. В этот раз перепробовал уже три последние версии, и даже с версией SDK происходит пустой экспорт.
Суть в чем, на работе не хочет правильно экспортироваться, причем с виртуальной машины этого же компьютера все правильно экспортируется. Дома, все тоже нормально экспортируется.
Экспорт не работает даже с кубиком в сцене, поэтому пока не буду прикреплять саму сценуParket_1.html

Хар-ки рабочей машины
win7 x64
I7-4770
gpu нет

Parket_1.htmlParket_2.html
Baasis - vk.com/baasis - vk.com/pro_blender
OS: Mint 18 Sarah x86_64 Linux 4.4.0-21-generic, DE Cinnamon, CPU: Intel Core i7-2600K CPU @ 6.3GHz, GPU: GeForce GTX 680, GeForce GTX 650 Ti, RAM 16Gb
Браузеры: неадекватный FireFox v49, не люблю но тестирую все на Google Chrome v54, вроде сойдет Vivaldi 1.4.589.38
 
Пожалуйста, зарегистрируйтесь или войдите под своей учетной записью , чтобы оставлять сообщения.