Форум

Релиз Blend4Web 15.09

02 октября 2015 15:47 #4196
А как на счёт того чтобы записать небольшой тутор по работе с менеджером проекта ?
Мы обновили вводную статью по созданию простого приложения. Теперь через менеджер проектов:
ссылка
Команда Blend4Web
02 октября 2015 16:27 #4200
Ответ на сообщение пользователя Иван Любовников
Мы обновили вводную статью по созданию простого приложения. Теперь через менеджер проектов:
ссылка
Продолжая тему корректного отображения на моих офисных железяках…

Если исправить это не поучится, то хотя бы warning бы вывести, и что бы его в api можно было отловить…
Пробовал эту сцену запустить на 15.07, там также выглядит этот пример.
Не стой, где попало… Попадет еще раз.
http://naviris.ru/
02 октября 2015 17:18 #4202

Продолжая тему корректного отображения на моих офисных железяках…
А что у вас за девайсы? Там, по-видимому, ошибка расчета прозрачности в нодовом материале - нужно исправлять.
Команда Blend4Web
02 октября 2015 18:05 #4203
Я писал об этом выше…
Ответ на сообщение пользователя Кирилл
Машина:
Chrome Версия 45.0.2454.93
Linux Mint 17.2 Rafaela 32-разрядный
Radeon HD 3470 стоковые драйвера

В консоли ничего подозрительного

Пример с рагдолом тоже не воспроизвёлся как надо out-1.ogv
Не стой, где попало… Попадет еще раз.
http://naviris.ru/
02 октября 2015 20:33 #4204

Ответ на сообщение пользователя Кирилл
Пример не запустился правильно с вашего сайта по ссылке https://www.blend4web.com/apps/code_snippets/code_snippets.html?scene=bone_api


Машина:
Chrome Версия 45.0.2454.93
Linux Mint 17.2 Rafaela 32-разрядный
Radeon HD 3470 стоковые драйвера

В консоли ничего подозрительного

Пример с рагдолом тоже не воспроизвёлся как надо out-1.ogv
Конфигурация:
`ooo/ OS: Arch Linux
`+oooo: Kernel: x86_64 Linux 4.1.6-1-ARCH
`+oooooo: Uptime: 4h 42m
-+oooooo+: Packages: 1074
`/:-:++oooo+: Shell: zsh 5.1.1
`/++++/+++++++: Resolution: 1280x1024
`/++++++++++++++: DE: XFCE4
`/+++ooooooooooooo/` WM: Xfwm4
./ooosssso++osssssso+` WM Theme: G-Talkie-Blue
.oossssso-````/ossssss+` GTK Theme: Xfce-flat [GTK2]
-osssssso. :ssssssso. Icon Theme: Matrilineare
:osssssss/ osssso+++. Font: Sans 8
/ossssssss/ +ssssooo/- CPU: AMD Athlon II X2 240 @ 2.8GHz
`/ossssso+/:- -:/+osssso+- GPU: Gallium 0.4 on AMD RV710
`+sso+:-` `.-/+oso: RAM: 4424MiB / 7987MiB

Проблема такая же, проверил ещё на 1-й машине(тоже самое)
./+o+- alexey@alexey-Aspire-5553G
yyyyy- -yyyyyy+ OS: Ubuntu 14.04 trusty
://+//////-yyyyyyo Kernel: x86_64 Linux 3.13.0-61-generic
.++ .:/++++++/-.+sss/` Uptime: 13h 44m
.:++o: /++++++++/:–:/- Packages: 2342
o:+o+:++.`..```.-/oo+++++/ Shell: bash 4.3.11
.:+o:+o/. `+sssoo+/ Resolution: 1366x768
.++/+:+oo+o:` /sssooo. DE: LXDE
/+++//+:`oo+o /::–:. WM: OpenBox
\+/+o+++`o++o ++////. GTK Theme: Not Found [GTK2/3]
.++.o+++oo+:` /dddhhh. Icon Theme: Not Found
.+.o+oo:. `oddhhhh+ Font: Not Found
\+.++o+o``-````.:ohdhhhhh+ CPU: AMD Phenom II N850 Triple-Core @ 2.2GHz
`:o+++ `ohhhhhhhhyo++os: GPU: Gallium 0.4 on AMD RS880
.o:`.syhhhhhhh/.oo++o` RAM: 2169MB / 3700MB
/osyyyyyyo++ooo+++/
````` +oo+++o\:
`oo++.
На другой же машине сайт blend4web.com виснет, возможно из-за анимации логотипа, т.к. страница загружается, логотип не анимируется и выводит сообщение о том, что вкладка не отвечает, вот конфигурация
`ooo/ OS: Arch Linux
`+oooo: Kernel: i686 Linux 4.1.6-1-ARCH
`+oooooo: Uptime: 20m
-+oooooo+: Packages: 793
`/:-:++oooo+: Shell: bash 4.3.42
`/++++/+++++++: Resolution: 1024x600
`/++++++++++++++: DE: XFCE4
`/+++ooooooooooooo/` WM: Xfwm4
./ooosssso++osssssso+` WM Theme: G-Talkie-Classic
.oossssso-````/ossssss+` GTK Theme: Xfce-flat [GTK2]
-osssssso. :ssssssso. Icon Theme: Faenza-Darker
:osssssss/ osssso+++. Font: Liberation Sans 10
/ossssssss/ +ssssooo/- CPU: Intel Atom CPU N550 @ 1.5GHz
`/ossssso+/:- -:/+osssso+- GPU: Mesa DRI Intel(R) Pineview M x86/MMX/SSE2
`+sso+:-` `.-/+oso: RAM: 353MiB / 2008MiB
03 октября 2015 11:16 #4207
У нас получается 3 конфигурации Radeon:

3470 - RV620
4350 - RV710
4200 - RS880

По всей видимости это проблемы в старом драйвере Mesa r600g (http://xorg.freedesktop.org/wiki/RadeonFeature/). Будем смотреть другие поколения видеокарт, использующие тот же самый драйвер.

Atom N550 использует GMA 3150, этот чип очень старый и не поддерживается нами. По-хорошему он должен быть внесён в чёрные списки в браузерах, чтобы вообще не инициализировать WebGL контекст.
Команда Blend4Web
https://twitter.com/AlexKowel
06 октября 2015 18:17 #4257

Продолжая тему корректного отображения на моих офисных железяках…
Если исправить это не поучится, то хотя бы warning бы вывести, и что бы его в api можно было отловить…
Пробовал эту сцену запустить на 15.07, там также выглядит этот пример.



Безболезнено исправленно. Исправления войдут в состав 15.10

Разработчик Blend4Web
06 октября 2015 18:21 #4258

Пример не запустился правильно с вашего сайта по ссылке https://www.blend4web.com/apps/code_snippets/code_snippets.html?scene=bone_api
Машина:
Chrome Версия 45.0.2454.93
Linux Mint 17.2 Rafaela 32-разрядный
Radeon HD 3470 стоковые драйвера



Исправлено с введением небольших ограничений. Исправление так же войдет в состав 15.10. В качестве решения проблемы в настоящее время можно использовать проприетарные драйверы для видеокарты.
Разработчик Blend4Web
 
Пожалуйста, зарегистрируйтесь или войдите под своей учетной записью , чтобы оставлять сообщения.