Апдейтер

30 сентября 2016 20:06 #12312
Может пора бы уже сделать апдейтер как в стиме?
Каждый релиз приходится качать по 1,3 гига и эта цифра постоянно растет.
В данный момент лично у меня получилось как. Скачал 16.08 версию, начал осваивать и через 2 дня вышла 16.09 и мега бонус через пару часов как скачал, выходит 16.09.1
Из версии в версию меняется не 1,3 гига и думаю стоит обновлять конкретно измененные файлы.

Стим проверяет хеш-сумму файлов и заменяет/скачивает только те, что не прошли проверку.
Уверен, что вы знаете про это все.
Я в вас верю
Baasis - vk.com/baasis - vk.com/pro_blender
OS: Mint 18 Sarah x86_64 Linux 4.4.0-21-generic, DE Cinnamon, CPU: Intel Core i7-2600K CPU @ 6.3GHz, GPU: GeForce GTX 680, GeForce GTX 650 Ti, RAM 16Gb
Браузеры: неадекватный FireFox v49, не люблю но тестирую все на Google Chrome v54, вроде сойдет Vivaldi 1.4.589.38
30 сентября 2016 21:26 #12314
Присоединяюсь. Не уверен на счет варианта стима, но какой-то похожий механизм можно было бы вести.
Инди-разработчик игр, фанат Blender
http://prandgames.com
30 сентября 2016 23:22 #12317
+1 + блендер туда же ))
Денис
01 октября 2016 01:31 #12319
Можно качать новые релизы с ГитХаба . Удобно и быстро.
03 октября 2016 13:19 #12391
Ответ на сообщение пользователя Prand
Присоединяюсь. Не уверен на счет варианта стима, но какой-то похожий механизм можно было бы вести.

Мне вообще нравится вариант апдейтеров как в онлайн игрушках. Запускается лаунчер, проверяют файлы, если все ок то появляется кнопка старт.

В варианте с b4w, можно в папку с SDK положить sh файлик, который запустит скрипт на проверку и догрузит с сервера не подходящие или новые файлы. И в даты релиза можно самому заходить в папку SDK и жать на этот файлик.
Baasis - vk.com/baasis - vk.com/pro_blender
OS: Mint 18 Sarah x86_64 Linux 4.4.0-21-generic, DE Cinnamon, CPU: Intel Core i7-2600K CPU @ 6.3GHz, GPU: GeForce GTX 680, GeForce GTX 650 Ti, RAM 16Gb
Браузеры: неадекватный FireFox v49, не люблю но тестирую все на Google Chrome v54, вроде сойдет Vivaldi 1.4.589.38
04 октября 2016 09:10 #12409
sh файлик, который запустит скрипт
sh эт не кроссбраузерно (по отношению к винде ) скорее запилить маленький питновский скрипт прямо в окружении блнедера.
Не стой, где попало… Попадет еще раз.
http://naviris.ru/
04 октября 2016 15:22 #12421
Ответ на сообщение пользователя Кирилл
sh эт не кроссбраузерно (по отношению к винде ) скорее запилить маленький питновский скрипт прямо в окружении блнедера.
Я знаю что это не кросплатформенно , но я то линуксойд и мне интересно сделать в первую очередь в пользу gnu/linux. Хорошая бы реклама получилась кстати: либо качайте полтора гига либо идите на gnu/linux ну и еще пару фич каких нибудь добавить, которые работают только на gnu/linux.
Злой я к виндузятникам
Baasis - vk.com/baasis - vk.com/pro_blender
OS: Mint 18 Sarah x86_64 Linux 4.4.0-21-generic, DE Cinnamon, CPU: Intel Core i7-2600K CPU @ 6.3GHz, GPU: GeForce GTX 680, GeForce GTX 650 Ti, RAM 16Gb
Браузеры: неадекватный FireFox v49, не люблю но тестирую все на Google Chrome v54, вроде сойдет Vivaldi 1.4.589.38
04 октября 2016 15:39 #12422
либо идите на gnu/linux
Идите как вы на гну… звучит так то грубовато)
Blend4Web и всё такое. Тридешу тридэ, моделю модели.
04 октября 2016 17:09 #12425
Ответ на сообщение пользователя Кирилл
sh эт не кроссбраузерно (по отношению к винде ) скорее запилить маленький питновский скрипт прямо в окружении блнедера.

+
Денис
04 октября 2016 22:03 #12432
А как вы собираетесь тестировать на совместимость с проектами, если оно просто сверху накатится? Смысл в том, что проект может поломаться и лучше иметь под рукой два релиза. А уж как устраивать всё на компе - от окружения зависит. Я держу два релиза и проекты отдельно. Когда надо - просто создаю ссылку в нужной версии и пробую. А вы как такое сделаете, если обновлялка будет? Хотя, да, последнее обновление качать ради исправленной буквы - как-то слишком. :)
 
Пожалуйста, зарегистрируйтесь или войдите под своей учетной записью , чтобы оставлять сообщения.