Форум

Не отображаются тени в браузере

23 января 2015 07:58 #1139
Настроил сцену как показано на уроках, но в браузерах тени не отображаются. Использовал мозилу и хром.
23 января 2015 11:27 #1142
Ответ на сообщение пользователя mirok
Настроил сцену как показано на уроках, но в браузерах тени не отображаются. Использовал мозилу и хром.
Если можете то прикрепите пожалуйста файл сцены в сообщении, или если что, то мне на почту mikhail-sb@blend4web.com
Менеджер и 3D художник Blend4Web
Запекайте Ambient Occlusion!!!
mikhail@blend4web.com
23 января 2015 16:27 #1147
Вот файлы
23 января 2015 16:37 #1148

Ответ на сообщение пользователя mirok
Вот файлы
Видеоответ
Также я об этом говорил в видеоуроке по установке SDK
Менеджер и 3D художник Blend4Web
Запекайте Ambient Occlusion!!!
mikhail@blend4web.com
23 января 2015 16:41 #1149
При много благодарен! Спасибо за быстрый ответ!

Кстати, классный дизайн сайта!
23 января 2015 16:44 #1150
Обращайтесь, если что и спасибо
Менеджер и 3D художник Blend4Web
Запекайте Ambient Occlusion!!!
mikhail@blend4web.com
22 июня 2015 12:01 #2793
Добрый день, у меня так же проблема с тенями, но маловероятно, что проблема в настройках. На одном компьютере тени отображаются, на втором нет. Браузеры - последняя версия хром, все обновления стоят, вин 7 про. Но на рабочем видеокарта nvidia, а на проблемном amd r290x.
Для проверки использовал как свои эксперименты, так и готовые примеры с сайта (софит).
Кстати, в ИЕ теней нет ни там ни там.
22 июня 2015 12:25 #2794
Добрый день и добро пожаловать на форум!
Насчет Internet Explorer - это вполне предсказуемое поведение. На нём до сих пор нет поддержки всего функционала WebGL в том числе Depth-текстур, которые нужны для отрисовки теней.

Насчет компьютера, на котором не рисуются тени:
Скажите, пожалуйста, какие наши демо-сцены вы на нём открывали. И приведите вывод с сайта webglreport.com для этой машины.
Мы тестировали движок на схожей видеокарте AMD r270 и таких проблем не наблюдали.
Разработчик Blend4Web
22 июня 2015 13:37 #2796
Я тестировал на черепахе, софит, машинима. Нигде теней нет. А вот от очков тень лежит, возможно там текстурой сделано, я не знаю.
22 июня 2015 14:58 #2801
Ответ на сообщение пользователя CyberLion
Я тестировал на черепахе, софит, машинима. Нигде теней нет. А вот от очков тень лежит, возможно там текстурой сделано, я не знаю.
У вас сильно урезанные возможности видеокарты - используется d3d9 вместо d3d11. И depth-текстуры так же нет в списке поддерживаемых расширений. Полагаю, если вы наберете в браузерной строке about://gpu, то будет информация о каких-то ошибках.
У вас случайно не APU от AMD стоит? Я сейчас исследовал этот вопрос и обнаружилось, что Chrome выключает dx11 на гибридной графике от AMD.
Разработчик Blend4Web
 
Пожалуйста, зарегистрируйтесь или войдите под своей учетной записью , чтобы оставлять сообщения.