Вопрос - ответ

15 июля 2015 16:08 #3039
На некоторых форумах прижилась традиция одной темы для мелких и одиночных вопросов.
Предлагаю сделать аналогичную тему и тут.


_________________________________________
Начну со своей небольшой проблемы: сделал сцену и экспортировал в .html, на моем компьютере она открывалась как надо, без нареканий. Поделился с товарищем на его планшете она открылась вот так: скриншот
.
После этого я выделил все объекты и применил к ним ctrl + a. Масштаб и поворот.
С тех пор экспортированный из него html зависает при загрузке в браузере. Замирает индикатор на 39%. Все материалы перепроверил, опции, но не нашел причину.

Исходник:
RMO.blend

Старая версия (которая глючила на планшете): engine9.ru/ris_logo.html
https://sketchfab.com/engine9/models
16 июля 2015 09:57 #3048
Интересно, проблема появляется только при экспорте в HTML, в JSON все экспортируется и работает хорошо..
Разбираемся
3D Художник (Generalist), администратор конкурсов,
команда Blend4Web
арт блог: http://contret-art.tumblr.com/
16 июля 2015 11:24 #3050
У меня аналогичная проблема была когда мешу был назначен материал использующий две UV, а у меша вообще не было UV. При экспорте все проходило нормально, а файл так же зависал на 39%. Может как-то связано?
https://sketchfab.com/engine9/models
16 июля 2015 11:39 #3051
Нашли багу, спасибо
Суть в том, что при отключенном антиалиасинге и включенном моушен блюре одновременно сцена крашится. К следующем релизу пофиксим, а пока достаточно либо включить антиалиасинг, либо выключить моушен блюр

А насчет планшета вашего товарища - подскажите, какой планшет? В каких браузерах проверялось?
3D Художник (Generalist), администратор конкурсов,
команда Blend4Web
арт блог: http://contret-art.tumblr.com/
16 июля 2015 13:04 #3054
Спасибо! Он работает в b4w :) Угадаете?
https://sketchfab.com/engine9/models
16 июля 2015 14:14 #3055
Угадал
Поколдуем)
3D Художник (Generalist), администратор конкурсов,
команда Blend4Web
арт блог: http://contret-art.tumblr.com/
16 июля 2015 15:04 #3059
Вот еще вопрос, вероятно он относится к самому блендеру. При рисовании цветом вершин сетка получается намного ярче чем выбранный цвет, от чего попасть в оттенок почти невозможно. Чтобы назначить насыщенный и темный цвет приходится рисовать почти черным. Это так и должно быть? Посмотрите, объект закрашен цветом который выбран и выглядит намного светлее: http://i.imgur.com/4Vd7Q9e.png
https://sketchfab.com/engine9/models
16 июля 2015 15:27 #3061
А это из-за цветового пространства. Во вкладке сцены в панели color management можно поиграться с настройками.

Мы пока только sRGB поддерживаем
3D Художник (Generalist), администратор конкурсов,
команда Blend4Web
арт блог: http://contret-art.tumblr.com/
24 июля 2015 18:53 #3184
В orphan data висит куча одинаковых мешей с 0 юзеров. Почему они не удаляются при сохранении и как их оттуда удалить? Клик на крестике назначает фейкоюзера.
https://sketchfab.com/engine9/models
27 июля 2015 17:07 #3197
Ответ на сообщение пользователя Андрей
В orphan data висит куча одинаковых мешей с 0 юзеров. Почему они не удаляются при сохранении и как их оттуда удалить? Клик на крестике назначает фейкоюзера.

Если честно ни разу туда не заглядывал, всегда удалял с шифтом что ненужно, либо если много такого просто несколько раз делал CTRL+S –> SHIFT+CTRL+O(переоткрыть эту же сцену) Х2-3 раза и объекты без юзеров отваливаются, если не поможет попробуй с шифтом удалять из соответствующей панельки (изображения в текстурах либо в uv/image editor, mesh во вкладке mesh (Data))
Либо вот такой трюк есть вроде:
http://www.katsbits.com/htm/google-archive.php?subaction=showfull&id=1219914894&archive=&start_from=&ucat=12&
Менеджер и 3D художник Blend4Web
Запекайте Ambient Occlusion!!!
mikhail@blend4web.com
 
Пожалуйста, зарегистрируйтесь или войдите под своей учетной записью , чтобы оставлять сообщения.