Forum

Image sequences in HTML or Preview

06 November 2015 04:43 #4822
I have been learning blend4web and am really enjoying the product, however I cannot seem to get image sequences to show. I have a series of images that have been animated and are a numbered sequence of png files.

I can add them on to a plane, for example, and verify in blender that they do infact show, and play correctly, however I cannot see the images (just a blank grey plane) when I either use fast preview or export to HTML.

I tried using the export converted media options and a few other, I have no issues with single images and video textures but the sequences dont seem to work.

Am I missing something basic?

Ben
06 November 2015 06:29 #4823
Hi ben,
Can you attach a .blend file? You can use the "Attach" button when writing your post. Also in Blender go to File > External Data and check "Automatically Pack Into .blend", then save. That way your images will be part of the .blend file.

Also, here is a video where I put an image texture on a sphere at about 5min 30 sec in.
https://www.youtube.com/watch?v=STYq5qQ2w2E
~Will
Blend4Web Videos
https://www.youtube.com/channel/UCp6x8JP7oCiiTjbJorPPMsQ/videos
09 November 2015 11:08 #4853
Hi Will,

Thanks for the speedy response. Work was busy over the weekend but I have had a chance to try what you suggest.

Here is a really simple blend, with an image sequence as the texture for a plane. When either using the export to html or fast preview I just get a grey plane. I saw in another post in this forum that image sequences are supported so am wondering what I am doing wrong.

When I use the automatically pack into blend option, it reports no new files were added.

The image sequence is 75 images , eye_0.png to eye_75.png. Changing the start and offset options inside blender does indeed show it loading the other images from the sequence.
09 November 2015 14:30 #4855

saw in another post in this forum that image sequences are supported so am wondering what I am doing wrong.
Sorry, but this feature is not supported, you're probably missed up with something else.
Blend4web and that kind of thing.
09 November 2015 15:30 #4857
According to this post it was released in 15.04

https://www.blend4web.com/en/forums/topic/65/

I tried to use a movie instead, but can't seem to make the alpha appear as anything other than black. Anyone got any suggestions for me?
09 November 2015 21:22 #4863
Hi ben and welcome!

Blend4Web supports custom sequence format to be used as fallback for videos in Internet Explorer and on iPhone. This is not what you probably want. Still you can use image sequences for animated effects such as fire if you put all your images in an atlas and use shader nodes to shift the UV with time. I'll ask our guys to prepare an example for you tomorrow.
Development Lead | Twitter
10 November 2015 14:23 #4881

According to this post it was released in 15.04

https://www.blend4web.com/en/forums/topic/65/

I tried to use a movie instead, but can't seem to make the alpha appear as anything other than black. Anyone got any suggestions for me?
You can use this example for your needs, but you will need to place all your frames in one texture atlas as it done in the example. There you can find some explanations in node material.
sequence_example.blend
Blend4web and that kind of thing.
 
Please register or log in to leave a reply.