Forum

Play Timeline vs Play Animation

11 December 2015 20:14 #5826
When should we use Play Timeline, and when should we use Play Animation instead?

They are described in the manual, but I'm not sure how to decide which one to use.

One reason I ask is that I haven't been able to get Play Animation to work.
Here's a .blend demonstrating Play Timeline working on a tetrahedron, and Play Animation not working on a cube (nothing happens when you click the cube). Each has its own node tree. I probably just overlooked something.
11 December 2015 22:29 #5827
Your .blend link is broken.

You should use "Play Timeline" if you want to control global timeline animation. This is something like a slider in the video player. It controls the NLA-animation. See iq_test.blend.

If you want to play concrete object animation you should use "Play Animation". See piano.blend, node_play_anim.blend.
Alexander (Blend4Web Team)
12 December 2015 03:49 #5829
Thanks, Alexander!

Sorry about the broken link. It should be okay now. I had renamed it in Dropbox, but that change hadn't taken effect.

I basically get the concept of what you mean. I don't have those .blend files in my SDK - are they only in the pro version?

I will show a few of the setups I have tried that didn't work. Some of them may be valid connection types but I'm doing something else wrong. Others may not be valid connection types. I'm hoping to receive some feedback from the forum community on what I've got right or wrong.

1. (Two 'Entry Point' nodes in the same node tree)

.blend file

2-A. (Cone has its own node tree)


2-B. (Cube has its own node tree)

.blend file

3. (One 'Switch Select' node for both objects)

.blend file

As you can see, I've tried various approaches, and I'm curious to know what's possible. But I still haven't had success.
12 December 2015 15:52 #5832

I basically get the concept of what you mean. I don't have those .blend files in my SDK - are they only in the pro version?

I have these examples in the free sdk in "Blend4Web/blender/interactivity" directory.

I will show a few of the setups I have tried that didn't work:

To use "Play Animation" you should specify a correct Animation names, for example "ConeAction" but not "Scaling" (see documentation for right sources of allowed animation names; names for animation actions you can find in Dope Sheet editor) . Also you needn't to make NLA tracks, but keep in mind to set "Fake user" if the action is not used anywhere.

You are using "Do not wait" in sequence of two "Play Animation" nodes that is applied to the same object. For now the second animation will overwrite the previous. In the future we will add the animation slots to make it possible to apply more then one animation.
Alexander (Blend4Web Team)
13 December 2015 09:17 #5841
Thank you for all the helpful info!

I didn't know about the 'interactivity' directory. It looks like there are many helpful example files in here, so I will study them all.

I looked through the documentation for the list of allowed animation names, but I didn't see it. Could you please tell me what section it's in?

So for now if I need more than one animation to play at a time on an object I will use the Play Timeline node.

P.S.
iq_test.blend had an unresponsive script when I opened it in Firefox.
Script: http://localhost:6687/src/renderer.js:502

Also, node_play_anim.blend has a missing asset, it seems. When I open the .blend I get:
…/Documents/blend4web_sdk_free/blender/capri/props/sunglasses/sunglasses.blend': No such file or directory

These interactivity demos are great though! I'm already learning some new things from them.
14 December 2015 10:44 #5842

I looked through the documentation for the list of allowed animation names, but I didn't see it. Could you please tell me what section it's in?
link

iq_test.blend had an unresponsive script when I opened it in Firefox.

Checked on firefox 42.0 - all is ok. What version are you using?

Also, node_play_anim.blend has a missing asset, it seems. When I open the .blend I get:
…/Documents/blend4web_sdk_free/blender/capri/props/sunglasses/sunglasses.blend': No such file or directory

Will fix it.
Alexander (Blend4Web Team)
14 December 2015 11:47 #5845
Thank you.
I am using Firefox 42.0 also - OS X 10.6. It may be because that computer is an old MacBook Air and doesn't perform well. I will test on my iMac later and let you know if I still get the error.

Update: I only get the error on my MacBook Air. On my iMac running OS X 10.10.1 it runs fine.
 
Please register or log in to leave a reply.