Forum

several animation looping in node tree[solved]

08 January 2016 01:21 #6305
Hello!
I am doing a scene in witch i need two animations to play simultaneously. I had one looping at the root of my node tree. But when i added the run cycle on the armature of the character the first animation stopped.

Blend attached.

Thank you all for your precious help!

08 January 2016 13:33 #6321
Ok solved it!
Well let's say that it works with several armature_B4W_BAKED animation. With ObjectAction i could only make one work at a time. Or not a B4W_BAKED and an Action. So i added a bone to my seen and baked a simple 360 rotation that i was trying to do directly with the object. Why not? Now that i figured how to bake animation why not take advantage of it?

As always thanks for the good work B4W team !
08 January 2016 13:53 #6326

Ok solved it!
Well let's say that it works with several armature_B4W_BAKED animation. With ObjectAction i could only make one work at a time. Or not a B4W_BAKED and an Action. So i added a bone to my seen and baked a simple 360 rotation that i was trying to do directly with the object. Why not? Now that i figured how to bake animation why not take advantage of it?

As always thanks for the good work B4W team !

You are right, now you can apply and play only one anomation at a time. I think, we will improve Play Animation node to make it possible to mix several animations.
Alexander (Blend4Web Team)
08 January 2016 23:58 #6362
Ok looking forwards to it !
 
Please register or log in to leave a reply.