Forum

Object Outlining persists even when disabled

10 March 2016 01:37 #8121
I have a scene with only one object that I want to be selectable, and when it is selected I would like it to momentarily show a glowing outline.

The problem is that whether I set it to ON, OFF, or AUTO, I still get outlines on everything.



I've also tried turning off Object Selection, just to see if it made a difference. It did not.



The one object that I do want to be selectable has these settings:



Any ideas?
Thanks.
10 March 2016 10:38 #8128
Hello!

In case you test your scene in viewer (for example with Fast Preview button) please check if "Overview Outlining Mode" property is set to No
Blend4Web Team - developer
11 March 2016 05:31 #8172
Thank you for that info! In my case Overview Outlining Mode is not being enabled/disabled depending on my B4W Render settings.

I do this in Blender:



But I see this in the Viewer:



Unless "Object Outlining" and "Overview Outlining" mean two different things?

I realized that when I do File > Export > Blend4Web (.html) that it displays as expected. So maybe it is just that the Viewer's settings for outlining are independent from those of the .blend?
11 March 2016 10:07 #8181

I realized that when I do File > Export > Blend4Web (.html) that it displays as expected. So maybe it is just that the Viewer's settings for outlining are independent from those of the .blend?
You are absolutely right!
It is viewer debugging tool that explicitly sets Object Outlining property to ON if enabled
Blend4Web Team - developer
11 March 2016 11:08 #8185
Thanks for confirming that!
 
Please register or log in to leave a reply.