Forum

Uncaught TypeError: Cannot read property 'length' of undefined

19 March 2016 02:55 #8358
I got this error in the console. What does it mean, and how can I fix it?

I found a Stack Exchange question about it, but I don't know where this code exists.

Here is my .blend.

Thanks in advance!
21 March 2016 12:14 #8391
Problem solved by un-checking env1 in the texture tab. No idea what or why… Just cheer luck.
I hope that give you the desired render though.

I noticed that sometimes when you mess thongs up in the blend file you get that kind of error. It looks like it's JavaScript but it really has something to do with your file. Last one i can remember was caused by an image i created in the editor but didn't save. It worked perfectly in the viewport but couldn't export. I warned me about undefined something as well.

Good luck!
21 March 2016 20:58 #8412
Hi Luke! Thanks for taking a look. Well, that is very strange - it seems my 3D scene texture is causing a problem. I have used 3D scene textures before with no trouble, so I'm surprised there is a problem with this .blend. I will continue to test it.
 
Please register or log in to leave a reply.