Forum

Object's animation always different than when viewed in Blender

23 June 2016 17:32 #10200
I have a rigged and animated quadruped (a cat) that has to bound over some terrain, so I've keyframed Loc Z and Rot X values on the armature object to make the mesh touch the terrain at the points in the walk cycle where the feet would push off from the ground. To put it simply, my armature is animated so the feet touch the ground.

When I play the animation inside Blender everything looks just fine, but when I do a Fast Preview in Blend4Web it's completely different. Either the cat ends up underground, or ends up passing through the hills like a ghost (depending on what I've tried).

Things I've tried so far include doing "Bake Action" of the Object and the Pose (with and without clearing parents / constraints), and also pushing down NLA actions as strips (I'm not sure if this is always necessary or not).

Here's the .blend

If anyone can tell me what I'm doing wrong I would really appreciate it!
23 June 2016 18:13 #10201

When I play the animation inside Blender everything looks just fine, but when I do a Fast Preview in Blend4Web it's completely different. Either the cat ends up underground, or ends up passing through the hills like a ghost (depending on what I've tried).
Sorry, but I see intersections in Blender too. Try to create NLA strip for cat and set a real 36 frames that your animation have, but you set less. So if you set 36 frames you will see that you see in the engine. The engine dos'nt support not integer values in frames, so it rounded the number to 35 and your animations out of sync.
Blend4web and that kind of thing.
24 June 2016 17:45 #10214
Thank you for pointing that out, Mikhail!
I hadn't even noticed the sync discrepancy, actually. I was so focused on the intersection problem.

Would you mind telling me what happens to the position of the cat when you do a Fast Preview?
27 June 2016 10:33 #10232

I was so focused on the intersection problem.
The reason why you see intersection in viewer and didn't see it in Blender is no sync between moving of the cat and the terrain.


Would you mind telling me what happens to the position of the cat when you do a Fast Preview?
What do you mean? There's no difference between Fast Preview and any other export method.
Blend4web and that kind of thing.
 
Please register or log in to leave a reply.