blend4web installation - Blender 2.77a Not Responding

02 September 2016 09:56 #11574
Hello everyone,

Thanks for all your help on this forum.

I installed blend4web by downloading Blend4Web CE. (Is this the same as the SDK?)

I copied the folder but put it in C:\Program Files instead of C:\

In Blender I pointed the Scripts: to that location.
I enabled the add-on in User Preferences and it worked.

But now, if I close Blender and re-start Blender, the second time I open it, it says "Not Responding"
And I cannot open a new session of Blender until I restart my PC.

So I moved the installation folder to C:\ and pointed to the new location in User Preferences. Blend4web does work, but it still makes Blender freeze up if I try to close and re-open it, which I do all the time.

Attached some images.

Any ideas how to fix this?
Thanks :)
02 September 2016 10:06 #11575
Attaching screen shot of Blender not responding.

If I disable the b4w add-on in User Preferences and restart my PC the problem goes away.
02 September 2016 11:33 #11582
Hello everyone

I installed blend4web by downloading Blend4Web CE. (Is this the same as the SDK?)
Yes, CE is Community Edition of SDK. It was just recently renamed

What version of Blender are you using? Is it stable?

Could you try to disable Development server running on startup in Blend4Web addon properties? And try to reproduce the behavior with hanging.
Alexander (Blend4Web Team)
05 September 2016 08:04 #11609
Hi Alexander Romanov,

I am using Blender 2.77a. I believe it is stable. It has worked very stable for last couple months.

Your suggestion worked. I disabled Development Server. Now it never hangs. I cannot break it anymore.

Thank you, very helpful!
05 September 2016 08:33 #11611
This just helped us to detect the issue. We will try to reproduce and fix it.
Alexander (Blend4Web Team)
Please register or log in to leave a reply.