Forum

Scene interactive in Chrome, Edge, IE problem!

06 September 2016 18:02 #11643
Hello,
I created a simple scene in project manager and add an html+css menu.
I exported scene in json+bin but while in firefox it's correct in chrome or edge it isn't
visualized, i see only menu.

What's the problem?

Thanks, regards!
07 September 2016 09:12 #11648
Hi

Please give us more info, or .blend file and version

Thanks
07 September 2016 10:22 #11649
Also, are there any errors/warnings in the browser console (F12)?
Blend4Web Team
07 September 2016 11:56 #11651
Hi,
i don't see any errors/warning in the browser console.
It seems as if main_canvas_container does not loading scene….
Anyway also the web_page_integration example (\deploy\tutorials\example) does not work in chrome and edge, while in firefox it works.
I try other examples (ie: interactive_web_application\simple_app.html) but in chrome and edge they are not loaded.

I attached .blend file….


Thanks!
07 September 2016 12:05 #11653
Instead,
the html exported directly from Blender works both in Chrome, Edge, Firefox…..
07 September 2016 14:46 #11657
Are you using the development server when you open the scene? The address to your project should be like http://localhost:6687/apps_dev/my_project/my_project.html. Otherwise, if you open it via "file" URI like file:///C://…/my_project.html, the external resources won't be loaded because of the Same Origin Policy restrictions.

That's why an html-file works without problems, because it has all the resources in it.
Blend4Web Team
07 September 2016 15:41 #11660
Ah ok!
Perfect!
I understand….
Now all it works!
I don't understand because i saw scene ok in firefox but not in chrome, edge, ecc….

Thanks!
 
Please register or log in to leave a reply.