Forum

NLA bone animation always starts from 1st frame

08 September 2016 15:35
I made scene with 2 separate armatures and 2 animation which get played by press of 2 separate buttons.
second press on button stops that animation.
Something like one here (but with bones animation):
https://youtu.be/rdXHaZ1tAeY
However I run into a problem, on second press animation stops in ie frame 45, when I press button again it plays from beginning making visible "jump".
Both animations are cyclic (or ping-pong to be precise).
I tested it only on 1 bone and it worked as it should. it continued animating.
Using latest blend4web 16_08…
Is there some workaround? or I am just missing something?
12 September 2016 11:08
Welcome to our forum!

Can you attach here your .blend file with an issue?
19 September 2016 13:27
Thanks,

Meanwhile I put scene online:
B4W Scene

..and here is .blend source
Blend file
20 September 2016 12:12
Both animations are cyclic (or ping-pong to be precise).
I tested it only on 1 bone and it worked as it should. it continued animating.
Using latest blend4web 16_08…
Is there some workaround? or I am just missing something?
Hello!

Sorry for the delay!
It seems that you found a little bug! Thank you for the feedback

So the issue appears when an object has baked and non-baked versions of the action. So obvious workaround is to delete baked or raw version of the action from the blend file. Then everything should work fine.

We'll fix this issue in the next release!

BTW nice scene
Blend4Web Team - developer
20 September 2016 12:51
Thanks, will try it.
I will have bunch of similar scenes with various products, this is the first one.
My idea was to be able to pull the parts by mouse and when released, it returns to "rest" position (with dynamics) but I lack knowledge how to do it, so I made a compromise with animation
20 September 2016 13:41
Thanks, it worked.
But raw action needs to be deleted; if Baked Animation is deleted, only parts(bone) with keyframes are moving.

BTW You made great and powerful product! Keep up the good work!
20 September 2016 15:37
Thanks, it worked.
But raw action needs to be deleted; if Baked Animation is deleted, only parts(bone) with keyframes are moving.
Glad I could help
Blend4Web Team - developer
 
Please register or log in to leave a reply.