Blend4Web won't show up in addon list

07 November 2016 19:10
I've just downloaded Blender 2.78 for Linux x64 and the latest version available of blend4web ce.
After I enter the extracted sdk directory under "Scripts" and restart Blender, Blend4Web won't display in the Addons Tab > Import-export as expected.
I've even tried changing the path (initially it was on a different partition) to the same where Blender is installed but nothing changed.
The unzipped sdk is about 2.6GB and the only thing I haven't tried yet is to re-unzip.
What files does Blender look for in order to identify the Blend4Web addon?
07 November 2016 21:33
Hi, Andrew!

The SDK should have the "addons/blend4web/" folder in its root. This folder should contain such files like, and others.
Also, did you follow this installation instruction: link?
Also, are there any errors (possibly related to blend4web) in Blender's console when you launch it?
08 November 2016 01:24
One Pitfall is that if any time you try to remove the addon, it can actually delete some of the Blend4web files from the SDK directory. I have solved this issue by installing a freshly unpacked version of the SDK and as well you may want to reinstall blender. I have my SDK on a portable drive and move it between Windows and Ubuntu with great success. But while setting that up I had issues like you described. It seems like if you put the SDK on one drive and then try to change it to another drive Blender can remember some of the older settings. Reinstalling Blender solved this for me.
08 November 2016 16:27
So for some reason Ark messed it up while unzipping the SDK and probably did corrupt all files (I saw an error concerning in the console), so I used unzip and everything works fine now.. thanks!
Please register or log in to leave a reply.