Forum

[SOLVED] when import proyects from 16.09 to 16.10 get 2 errors

14 November 2016 13:05 #13818
Hi guys!.
when import proyects from 16.09 to 16.10 get these two errors:
Uncaught Error: Module "__texcomp" not found()
b4w.js:198 Uncaught Error: Module "__navmesh" not found()

Only have these modules:
// import modules used by the app
var m_app = require("app");
var m_cfg = require("config");
var m_data = require("data");
var m_preloader = require("preloader");
var m_ver = require("version");
var m_scn = require("scenes");
var m_mat = require("material");
var m_sfx = require("sfx");
var m_objs = require("objects");

Any help? Thanks.
14 November 2016 14:46 #13819
I have solved, my solution:
I created a new test project and I copied and pasted(overwritten) the:

<script type="text/javascript" src="../../src/b4w.js"></script>
<script type="text/javascript" src="…….></script>
<script type="text/javascript" src="…….></script>
<script type="text/javascript" src="…….></script>
<script type="text/javascript" src="…….></script>
<script type="text/javascript" src="…….></script>
…….

In your main.html.
And now its works well.
14 November 2016 17:52 #13824
you can use the check modules in the project manager and click the update modules button.
14 November 2016 23:24 #13828
Reply to post of user Mike
you can use the check modules in the project manager and click the update modules button.

Thanks, This work well, and is more easy!! :D
 
Please register or log in to leave a reply.