Forum

[SOLVED] Annotation missing bottom part of text

15 November 2016 23:09 #13853
Hello,

Update: Looks like Bootstrap conflicts with Blend4Web! Please see my post below!

I have created a semi-transparent overlay on top of my Rails web App - where I initialise Blend4Web - and I am currently testing with one of your demo scenes - the solar system - in order to test my code.

However, I have noticed that the annotations are missing the bottom part of the text. I was just wondering if there was anything I should look for to debug this? I have tried using Chrome's debug console etc.

I have found the line which is causing it to not display correctly:

element.style { height: 105px; }


When I uncheck this in Chrome it renders perfectly!

I have attached a screenshot.

I realise I will definitely have to get the PRO license so I can get technical support from you guys, because I am getting increasingly technical with what I am working on.

Thanks,

Andrew
17 November 2016 23:46 #13918
Looks like Bootstrap conflicts with Blend4Web!

When I comment out my bootstrap include in my CSS it fixes everything.

Now I have to find a way to prevent Bootstrap from conflicting with Blend4Web's annotations!!

I will keep you posted about a possible fix for this

One option is to wrap the entire Bootstrap CSS inside a wrapper, but I would like to avoid this if possible..

If anyone has this issue please read this guide; https://formden.com/blog/isolate-bootstrap
18 November 2016 14:46 #13937
Thanks for the heads up. I use lots of annotations in one of my projects and was considering Bootstrap and jQuery for some things.
On a side note I recently purchased the Pro version and found that the extra assets alone made it worth the money. For me being able to pull in professional materials in seconds made a huge difference.
~Will
Blend4Web Videos
https://www.youtube.com/channel/UCp6x8JP7oCiiTjbJorPPMsQ/videos
18 November 2016 21:01 #13959
@Will thanks for that. I will defo be going PRO soon after a few more paycheques have arrived.

I have filed an issue on GitHub with the bootstrap-sass Ruby gem that I am using, anyone using Rails and Bootstrap may find this useful, hopefully there will be some answers;

https://github.com/twbs/bootstrap-sass/issues/1094


I found something on StackOverflow also:

http://stackoverflow.com/a/11841935/6888582
 
Please register or log in to leave a reply.