No camera selected, unsupported sensor type

08 December 2016 23:34
I've made a scene with one camera, and i've tried deleted and adding that camera again a few times. When i open the scene with Fast Preview, it says no camera is selected. Also, when i check the camera properties, under Camera > Sensor there is a warning saying 'Unsupported sensor type'. The field there is set to Auto. I didn't change any setting when i added the camera, it is just the default camera you get when you add a camera.

There had been a 'Missing Active Camera' error, but that has been eliminated now that there is a new camera, and i cleared out some non-existent cameras that had somehow stayed on that list. But the preview still sees no camera. What is wrong here?

Thanks for your help.
09 December 2016 02:39
Okay, the scene is working now. It may have been just that the model was adapted from another scene and was very far from the origin. I'm not sure.
09 December 2016 11:10
under Camera > Sensor there is a warning saying 'Unsupported sensor type'
This option just affects the camera field-of-view. The engine supports only the "Vertical" sensor type and always use it regardless of what is set in the blend-file. This warning means that after the export you will get the camera field-of-view somewhat different from what you see in Blender. Generally, this warning can be just ignored.

There had been a 'Missing Active Camera' error
This error appears if the "Scene->Camera" setting is blank:

This field specifies which camera will be used for rendering, i.e. the main camera. Normally, it's set to a one of the presented in a blend-file cameras, but can be cleared indirectly as a result of some manipulations with them.
09 December 2016 19:23
Thanks for that complete answer. I'll bear those things in mind in future.
Please register or log in to leave a reply.