Blend4web never appears on the "Add-ons" tab

05 March 2017 08:36
Hello, I am new to Blend4web and very interested in getting it working on my Windows 7 system. I have followed the instructions and viewed several videos, but Blend4web never appears on the Add-ons tab so I can't activate it.

I have tried:

-Uninstalling/reinstalling Blender 27.8c.
-Uninstalling/Reinstalling Blend4web.
-Downloading Blend4web three times in case there was a problem with the file.

The "blend4web_ce folder" is in the "C:\Users\Jim\AppData\Roaming\Blender Foundation\Blender\2.78\scripts\addons" directory, which I believe is the correct place. Blender is correctly seeing other add-ons which are in that same folder, so whatever paths are set up in Blender appear to be right.

I used the Blender Windows installer so Blender is in the default C:\Program Files\Blender Foundation.

In case it matters, Blender froze every time I selected "Install from File" so it's possible some essential file did not get moved into the blend4web_ce directory, but the folder has gigs of information so it seems to have unpacked correctly. I also tried manually unzipping blend4web_ce and copying it into the \AppData… directory but it still doesn't appear as an add-on within blender itself.

I of course rebooted my Win 7 system and made sure there was plenty of memory and hard drive space.

Any suggestions? I notice that the other add on has a __init__ python file, but the blend4web_ce folder does not. Is there some way to force Blender to activate it besides the checkbox in the UI?
06 March 2017 08:40
I tried today on a second Win 7 computer and had exactly the same behavior. Blender freezes when I click "Install from File." Strange.
06 March 2017 11:05
Hi! And welcome to our forum!

Installation of Blend4Web SDK is a bit different from addon installation.
Did you follow the installation instruction from our documentation?

Here is copy-paste from the doc:
  • Run Blender.
  • Open the User Preferences panel File > User Preferences….
  • Open the File tab.
  • Set the path to the SDK directory in the Scripts field.
  • Click the Save User Settings button.
  • Restart Blender.
  • Once again, open the User Preferences panel File > User Preferences….
  • Open the Add-ons tab.
  • Enable the Blend4Web add-on.
  • Once again, click the Save User Settings button.
Alexander (Blend4Web Team)
13 March 2017 06:38
Thanks! I didn't realize that I had to point the Scripts path one directory deeper to the SDK directory. Changing the scripts path did the trick.
18 January 2018 01:22
i have similar problems with finding blend4web addon,… i have scripts set to blend4web_ce_17_10_1/blend4web_ce/scripts/blender/

this gives me some more addons to choose from on addons tab, but not blend4web addon specifically.. whats me doin wrong?
18 January 2018 11:02
Hello! And welcome to our forum!

You should set scripts to blend4web_ce_17_10_1/blend4web_ce
Alexander (Blend4Web Team)
Please register or log in to leave a reply.