Forum

17.04 Cycles environment lighting example?

26 April 2017 00:30
Got the new RC but I'm having a difficult time replicating the example in the recent tweet: https://twitter.com/blend4web/status/856536053947256833

Anyone have a blend they'd like to share?

Thanks!
26 April 2017 10:32
Hello,

here it is
Blend4Web Team - developer
Twitter
LinkedIn
27 April 2017 15:17
Thanks Konstantin, that helps to confirm what I was attempting. It seems I had wrong expectations for how this feature would work and that I'll still need to do appropriate texture set-up to simulate image-based lighting. I'm still learning.

My expectation was that there would be some lighting going on, similar to Cycles (top left.) On an object with ~0.8 roughness I wouldn't expect so much reflection (top right.)
27 April 2017 15:28
Thanks Konstantin, that helps to confirm what I was attempting. It seems I had wrong expectations for how this feature would work and that I'll still need to do appropriate texture set-up to simulate image-based lighting. I'm still learning.

My expectation was that there would be some lighting going on, similar to Cycles (top left.) On an object with ~0.8 roughness I wouldn't expect so much reflection (top right.)
support of roughness for reflections is still experimental and in developing, for now roughness only affects direct lighting, not environment. But we are working hard on it

I will make a presentation on our pbr/cycles plans which will also address this theme in the upcoming b4w conference
Blend4Web Team - developer
Twitter
LinkedIn
27 April 2017 20:09
support of roughness for reflections is still experimental and in developing, for now roughness only affects direct lighting, not environment. But we are working hard on it

I will make a presentation on our pbr/cycles plans which will also address this theme in the upcoming b4w conference

Sounds great, I'll be watching remotely. Cheers!
18 July 2018 14:49
Hi!

A bit of an old thread but am I correct to assume that Environment lighting from a cycles Sky Texture doesn't work?

If I where to use an image with Environment Lighting set to Texture and no lights the model appears either unlit or very faintly lit, and none of the colour from the environment comes through, can this be remedied somehow?

Thanks!
 
Please register or log in to leave a reply.