Forum

Bug on 17.04

15 June 2017 12:30
Good morning. As usual compliments for work! I use Blend4Web for some projects. By downloading 17.04 I found several BUGs that did not exist before.
- Using VR mode, the camera is not positioned correctly
- Using as nodes -> entry point -> delay -> move camera
Entering VR mode the room goes crazy and moves randomly.
- I wrote a library of JS VR using Blend4Web as a reference. Unfortunately in VR mode the camera is incorrectly positioned and the Move Camera action of the node does NOT work.

I take the opportunity to know if there is a system to "activate" the click in VR mode using standard Blend4Web.
I attach the files.

thanks so much for everything!
16 June 2017 14:49
What browser build are you using? I got it working on Chrome experimental build and Firefox Nightly.
As for the move-camera node, the camera needs to follow the the headset tracking so I don't think you can have it controlled by a node if it is following your HMD. Maybe the move camera node is causing your camera to be positioned wrong.
16 June 2017 23:23
The test is performed under Android.
On pc, mac, linux the test works fine!
Up to version 17.04 on both Desktop and Android was working properly.
17 June 2017 00:17
I haven't tried anything on Android. I should try it out.
21 June 2017 10:53
Hi Will, new to bugs under android?
21 June 2017 12:16
For VR, ya, I haven't tried it much on mobile devices. I think it will work much better when you can have two hand controllers. Google's Daydream is almost there with one controller. I think we will have two soon.
I check my regular projects on Android. I don't generally find any bug.
 
Please register or log in to leave a reply.