Last update issues

15 July 2017 23:48
Hi there:

I have updated to the new version 17.06 and I am having quite a few problems with my existing projects. Maybe you can help me with some of it. I think I must not be the only one who have noticed it.

I was using a system for the cameras in a first person/third person shooter game I've been working on that involved moving the camera to the various positions using empties. And it stopped working with the new update. I have read the release notes and I've seen something has changed in the camera module, and in the constraints module too.

The problem is I was using append_copy_trans function of the constraints module to append the camera to the empties which in turn are parented to the physic body of the character using append_stiff constraints. It worked like charm in the 17.04 sdk but in the 17.06 sdk it doesn't.

All my intents to make it work in 17.06 were unsuccessful, I have tried with different constraints and without parenting to the empties but all I got was using an append_stiff_cam constraint, which is deprecated to append the camera to the character but it was working very badly, turning as it would have a lot of sensitivity, in turn with the recommended append_stiff function the frame rate would fall to only 7 frames per second I don't know why.

Then I got back to the 16.04 version but I was surprised with a strange behaviour in Firefox, which I've been using for time without a problem and I've seen the workers were getting disabled in the console as the app were being loaded. I don't know if this behaviour is caused by an update of Firefox or what. Previously it worked fine and the physics were logged as using their own thread, I remember.

So, Firefox were not allowing me even debugging which makes impossible to go on with the programming and I have had to change to Chrome. In chrome everything got back to normal, the physics thread working and the camera working right. Just fun again, thankfully.

Does anybody knows anything about this behaviours? I am surprised, mostly but the strange behaviour with the physics in Firefox. It was working with 17.04 until I updated Blend4Web and then when I redownloaded the 17.04 version it doesn't work anymore.

Hope someone can make a tutorial about the right way to use the cameras now as it seems to have changed quite a lot, until then it seems I'll stay with 17.04.
16 July 2017 04:33
Have you updated your SDK to 17.06.1?

Also might check modules. See this post.
16 July 2017 13:59
Hi Will, thank you for the response.

Well, I downloaded the file the 5th of July, the version in the version file inside the rar says just 17_06, is there other version? I'll try to download again.

Well, regarding the check modules thing, I can't see the post from that link, I don't know why but, I think I know what you mean, checking the modules from the project manager to update the files imports. Yeah, I tried that but it didn't work.

I've been working a little more since I wrote the post and I've seen the method that I use to bind the camera which is append_copy_trans from the constraints module I think it has been changed and the parameters are not the same like before.

I'm going to download the new file and see if it is really another version. I'm going to install it side by side with the old one and try to make it work. I would like to keep updating blend4web to get the new functionalities, it is a pity not to. But I think for this project the previous version were still working well I think it has everything I need for the project.

If you want to take a look at the project it is at GitHub but it is still the version that works in 17.04.

Thank you for the interest.

P.D.: Yesterday I've been seeing the video you have in the blend4web page, the one with the 3d glasses. Nice video. Maybe in a few years we all will see virtual reality as the normal way to browse, it is interesting.
Some time ago, I've been thinking of make a windows explorer with blend4web, you know, seeing the folders like rooms or some like that, I think it would be nice to walk inside the hard drive, something like Tron… With available teletransport of course…
16 July 2017 14:55
17.06.1 is a Pro only stability update. Forgot about that.
Have you looked at the FPS module API?
Specifically the enable_fps_controls().
This is the method used in the FPS example project. It has a bunch of options. VR ready to.
16 July 2017 18:31
I downloaded your project and ran it in the Project Manager. I was very amazed at how big it was. I ran all over your island in first person view. How is it supposed to work? Is there a way to go to 3rd person view?
17 July 2017 00:38
Hahaha, well it still doesn't do anything special. Just jumping around. You can change the camera with 'V' but you will see the character just have a silly animation. I just learned how to bake the animation and went to do other things. Now I have just figured out how to use the ray_cast to 'see' the objects and I will try to learn how to eat. I have already some fruits to spare around and it is going to be fun. I t is going to be a survival game but it has a lot of work to do yet…. Surely you're the first one to walk that island aside of me. I am going to update it often so if you want to keep jumping around you will be able to do it. I will make a post soon so if you want to play you can. It is a little joke but I hope it will grow.
What does surprise me is that it worked in your system, I don't know if I will have to wait for an update.
Thanks again for the feedback.
17 July 2017 07:52
It runs but I am getting this error that repeats continually.
Hard to tell what is causing it. Mean anything to you?

I have wanted to do a project like this for a long time but I never had the time. It looks like a fun project to learn from. Feel free to email me, maybe I can help you work the bugs out.
17 July 2017 09:17
In the past, I have found that using JS files from example projects can cause a problem. When B4W updates their SDK, they also update the example projects. This can leave you with outdated JavaScript. I am getting a variety of errors that make me think this could be the problem. The solution would be to get the new Petigor example files. The Update Modules function is finding a few things to update but there are still errors.
17 July 2017 11:20
Ah, yes, that bug is caused by the 'view' function I am impementing. When the ray hit an object with no physics it logs as an error report. Today I'm going to commit the new version that has that semi-corrected. Now it doesn´t log the error. Now the ray controls if the object has physics and if it doesn't doesn't take it into account.

I will warn you when it is updated.
17 July 2017 12:16
Ok, Will, it is updated, now the error shouldn't appear.

Looking at the picture you're using the builded version, does the development version work too? Maybe it works for you by using the update of Pro, I supposed there will be un update for the ce and will work too. Well, I am thinking if you use it from the build folder you really are using the version builded with 17.04. For now I am going to stay with the old version for development and I hope I will figure it out in the end with the new libraries. I think it has to do with the append_copy_trans method that has been updated to use the constraints from blender and I think in the parameters I use (obj, parent_obj, offset) and now it is (obj, parent_obj, influence). I am not sure yet.

Today I am going to begin with the feeding system, it is going to be fun, I have it pretty clear in my mind but will see what happens….

Will, I will mail you about the colaboration, it would be great to have someone to help….
Please register or log in to leave a reply.