Import projects to new 17_12 release

02 January 2018 18:30
Hi, I have installed the new addon and I´ve tried to import my projects which I had exported from 17_10 version of the sdk. I have tried several ways:

  • With the import projects button in the project manager I got a lot of red lines in the operation result screen and it suggested to update modules. I updated and the dev version in the project manager didn´t work.
  • Trying to import without updating in the import screen and updating each project separately didn´t work either.
  • Importing the folders and changing the imports manually in the html file, all the lines of the libraries by the one line import of the 17_12 version. I didn´t change anything in the javascript file. Here the app loads but it gets stucked when the scene would appear.

  • Am I missing something I have to change in the js file?
    My apps are the compiled type, can someone help me?
    02 January 2018 19:00
    Well, I have made another try and the results have been pretty confuse.

    I´ve been able to open the imported scene but it was having problems with the audio modules.

    TypeError: Argument 1 of AudioListener.setPosition is not a finite floating-point value. b4w.js:38658:5
    Int_SFX/exports.listener_update_transform http://localhost:6687/dist/b4w.js:38658:5
    update_transform http://localhost:6687/dist/b4w.js:17130:21
    update_transform http://localhost:6687/dist/b4w.js:17154:9
    update_worker http://localhost:6687/dist/b4w.js:29035:13
    Int_physics/exports.update http://localhost:6687/dist/b4w.js:28991:9
    frame http://localhost:6687/dist/b4w.js:76725:5
    loop http://localhost:6687/dist/b4w.js:76690:9

    Does the audio modules have changed since 17_10?
    02 January 2018 19:08
    Well, it seems it was somethig I was doing wrong.

    If you import the projects and reexport the scenes and check modules>update modules from the Project Manager it seems to work for most projects.

    Still I am having this issue with the audio, I don´t know if this is a bug or the audio module has changed, I´ll keep trying…
    03 January 2018 02:28
    This is strange. We have fixed this bug. Are you sure you are using Release but not Release Candidate or Developer Preview?
    Alexander (Blend4Web Team)
    03 January 2018 18:54
    Well, I downloaded it on Monday, January 1 from the download page. Maybe it is an old compilation.
    04 January 2018 00:36
    Could you attach a simple project to reproduce the issue?
    Alexander (Blend4Web Team)
    04 January 2018 02:36
    Hi again:

    I have download the actual version and it still happens in this project in particular, the one that has audio in it. When I reexport the scene it gives an error in the export if I do it from the project manager. If I export from Blender it exports ok, even with the strict mode on. But when I try to use the app it starts with the error in the post before. Plus I am having an error in the Blender console that reads Dag Zero … Not allowed to happen

    Does it make sense? Maybe is it something you know what is related to?
    04 January 2018 02:41
    Well, I tried to upload it but it is 35 Mb so it is not allowed. You have basically the same project in and the deployed project in . As it is exported with the 17_10 it works alright. Of course it is an ongoing project and it still has a lot of things to do.
    Please register or log in to leave a reply.