Forum

Procedural Skydome not working correctly

30 April 2015 16:59 #2223
Hi,

I´m trying to use the Procedural Skydome feature. After activating the checkbox "Procedural Skydome" under the Blend4Web "Sky Settings" in the "World Settings"-tab the generated html-File shows a deep blue background. Going back to Blender and changing the setting for "Sky Color" doesn`t seem to have any effect. The color remains deep blue after exporting the scene again. At https://www.blend4web.com/doc/en/outdoor_rendering.html one can find the tip: "Enable Sky Settings > Render Sky, then activate Sky Settings > Procedural Skydome", but I can`t find the concrete option "Render Sky". Can you help please?

Thanks a lot, Gilgamos
CG Generalist
3DWebbii.de (M&H Marketing AG)
30 April 2015 18:29 #2233
Hi, and welcome to the forum!

You are doing everything right. What Browser and version are you using? If you are under Windows and use Chrome 40 or Firefox 33-36, you probably suffered from the "Clear procedural sky hack". It helps avoiding serious bugs with these browsers' versions. If so, you need to update your browser.
Also, Procedural Sky uses Sun for calculations. If you have no Sun lamp on the scene, you will see a warning in the console and a black background.

If you want to use Blender's Sky settings, you can check this approach.

Please, let us know if you succeed.

[EDIT]
"Render Sky" option appeared in Blend4Web 15.04. I assume, you use 15.03 or earlier.
Blend4Web developer
04 May 2015 13:30 #2253
Hi Evgeny,

thanks for your reply. Obviously the effect was caused by the Browser-bug as you mentioned. I was using Firefox 33. I also updated to B4W Version 15.04, so the "Render Sky" option is available know. Cross-Browser-compatability is very important in my case, so I used a textured plane which is parented to the camera. That works fine.

Thank you,
Gilgamos
CG Generalist
3DWebbii.de (M&H Marketing AG)
 
Please register or log in to leave a reply.