Forum

Exported html error

30 October 2014 11:35 #375
A lot of errors when running the exported html. My question is that is B4W ready for production?
Below is the error msgs (Version: Blender v2.72b, Addon 14.10):
B4W warning: texture "water" has unsupported type "CLOUDS"
B4W warning: texture "Texture.002" has unsupported type "STUCCI"
B4W warning: texture "Texture.000" has unsupported type "CLOUDS"
B4W Warning: material "Material.001" is not assigned to any face (object "Plane.002").
B4W Warning: Mesh "Circle" has no faces (object "Circle").
B4W warning: depth-only issue was found
B4W warning: using NPOT-texture ../texture/grass/grass3.jpg
B4W warning: using NPOT-texture ../texture/stone/hrt_stone_07.jpg
B4W warning: using NPOT-texture ../texture/stone/hrt_stone_14.jpg
Uncaught TypeError: Cannot read property 'offset' of undefined
30 October 2014 12:10 #379
Hi, and welcome to our forum.

In the above report the only real error is in the last string:
Uncaught TypeError: Cannot read property 'offset' of undefined

All the others are warnings being described in our documentation.
First thing - you have exported your blend with Release Candidate version of our addon which may be unstable.
I would recommend downloading a new version and trying it.
If an error will occur ones more, please send your blend file to my email evgeny-ar@blend4web.com.

Blend4Web developer
30 October 2014 12:35 #382
Hi Evgeny,
Fast reply, amazing! Thanks!
I was using Blender 2.71 and Addon 14.09 (Mac OS 10.10), and the errors occured. So I updated to the lasted version, and the errors remain. I will send you the blend file later, FYI.
Another experiment: In order to figure out the problem, I tried using only one sphere and add some texture, then the error occured, either exporting error or runtime error.
Ps, I tried the demos in the SDK, all works well. Really wired. Waiting for your help!
30 October 2014 14:40 #383
Ответ на сообщение пользователя HTML5
Hi Evgeny,
Fast reply, amazing! Thanks!
I was using Blender 2.71 and Addon 14.09 (Mac OS 10.10), and the errors occured. So I updated to the lasted version, and the errors remain. I will send you the blend file later, FYI.
Another experiment: In order to figure out the problem, I tried using only one sphere and add some texture, then the error occured, either exporting error or runtime error.
Ps, I tried the demos in the SDK, all works well. Really wired. Waiting for your help!
There is really a problem exist. Normal maps crush with Generated texture coordinates which were recently supported by Blend4Web. Solution is to use UV maps for Normal Mapping. In the next release we will fix this.

As for the other messages from the console, you can fix them by removing Procedural generated textures (CLOUDS, STUCCI etc.), and by using Power of Two textures: 16x16, 128x128, and so on.

Thank you for pointing out the error.
Blend4Web developer
30 October 2014 16:07 #384
Hi Evgeny,
Really fast response, impressive! Well done!
Using the workaround is fine. But as a user, I hope all of the effects made by blender will be supported in B4W.
I like B4W, believe you will make it better!
Thanks again for the fast response!
07 January 2015 20:14 #967
hello,

I ran some simple cube, lighting and texture test examples from sketchup into blender and then exported using the opengl
plugin and they were all successful.

I am attempting to export a more complex sketchup model with the OpenGL addon and I am given this error
Export t… disk is forbidden

any help would be greatly appreciated.

Thanks.
07 January 2015 21:15 #971
Answered here.
Development Lead | Twitter
 
Please register or log in to leave a reply.