Forum

Animation with Logic Nodes

15 September 2015 23:47 #3831
Hi friends,
I am working on the next step of my links and animations. I have added a Play node with markers on the NLA animation strip. I have also added a sound in the Video Sequence Editor panel. The animation and sound work inside Blender but they are not exporting. I am hoping you can look at my attached blend file to see what I missed.

~Will
Blend4Web Videos
https://www.youtube.com/channel/UCp6x8JP7oCiiTjbJorPPMsQ/videos
16 September 2015 00:07 #3832
Hi Will,

For the animated Torus, don't forget to check the "Apply Default Animation" under the Object Tab, Animation Panel
16 September 2015 01:27 #3833
Ya, if I do that is plays continually. I need it to play only when clicked. I have the logic nodes set up to play a brief animation then page redirect but only after the object gets clicked.
~Will
Blend4Web Videos
https://www.youtube.com/channel/UCp6x8JP7oCiiTjbJorPPMsQ/videos
16 September 2015 10:42 #3841

Ya, if I do that is plays continually. I need it to play only when clicked. I have the logic nodes set up to play a brief animation then page redirect but only after the object gets clicked.
You need to convert all your animation into NLA strips and you don't need to check apply default animation on object when you use NLA strip.

animation.html
animation.blend
Blend4web and that kind of thing.
16 September 2015 20:15 #3869
> You need to convert all your animation into NLA strips

Is there any way of automating the conversion to NLA, even if it is during the export process ( convert, export, and then convert back )? That way, it becomes more what you see in Blender ( NLA animation or not ), you then see in Blend4Web.
16 September 2015 21:56 #3872
Great, thanks Mikhail! I am starting to get a handle on this. I am new to the NLA so I am on a learning curve. I did discover just now that an ogg sound works, whereas a wav does not. I remember reading something about that in the documentation.

crazyFolker, if you are doing a simple animation as opposed to the node logic triggered event we are talking about, you do not need to convert it to an NLA strip. Just make your animation, and put a check in the Default animation box on the Object panel. I will post all this in a video as soon as I am sure I have a good grasp of it.
~Will
Blend4Web Videos
https://www.youtube.com/channel/UCp6x8JP7oCiiTjbJorPPMsQ/videos
16 September 2015 22:38 #3873
Hi Will,

Yep, I meant about auto-converting for triggered events ( basically anything that makes it easier for a starter artist to get something working within Blend4Web ).

btw your tutorials are great, they gave me the push to spend some time in the last few days trying out the tech ( I had downloaded it previously to try out, but quickly gave up due to time constraints etc ).
17 September 2015 01:01 #3875
Ya Blender is not complicated enough already right?

The thing with Blender, its easy if you know how but bloody murder trying to figure it out if you don't.
~Will
Blend4Web Videos
https://www.youtube.com/channel/UCp6x8JP7oCiiTjbJorPPMsQ/videos
 
Please register or log in to leave a reply.