Forum

Select & Play Node Animation

21 October 2015 08:20 #4513
I am working on a project to explain the various types of logic nodes. It is based on your "node_play_anim.blend". I just have one question about the Animation Name field in the Select & Play node. I must misunderstand how it is used. Please see attached image and .blend.
~Will
Blend4Web Videos
https://www.youtube.com/channel/UCp6x8JP7oCiiTjbJorPPMsQ/videos
21 October 2015 12:59 #4518
Hi!
There are 3 possibillities:
  • Action:
  • Particle System of Emitter type:
  • Shader Action:

If field is empty it will play default animation (for example, active action).

We found a problem for your use case that is mix two types of animations, Timeline and Object. We will try to fix it.
Alexander (Blend4Web Team)
21 October 2015 17:24 #4522
Very good . Thank you. I will separate this into two projects for now.

I also noticed that when switching between tabs on the browser (Chrome and Firefox), the sound files play from random points. It is like the sound files are looping silently while you are viewing another tab then when you select the tab with the player running, the sound becomes audible for a short time.
~Will
Blend4Web Videos
https://www.youtube.com/channel/UCp6x8JP7oCiiTjbJorPPMsQ/videos
22 October 2015 11:36 #4531
I also noticed that when switching between tabs on the browser (Chrome and Firefox), the sound files play from random points. It is like the sound files are looping silently while you are viewing another tab then when you select the tab with the player running, the sound becomes audible for a short time.
This should be fixed in the upcoming release. Thanks for the feedback!
Development Lead | Twitter
 
Please register or log in to leave a reply.