Forum

Locked Camera

09 December 2014 14:03 #688
Hello everyone.
I've been having trouble with the latest Blend4web 14.11 and camera movement, some times the exported scene seems to locked and the camera wont move. The view is locked and wont orbit, and even the turntable option in the web viewer wont rotate.
I can recreate the problem even with Blender's default scene, just create a new scene, add a new camera and export the problem manifests both in Firefox and Chrome based. Even changing the camera type from target to free or any other won't work.
I've had trouble solving it, but it seems to be related to having several scenes in the same blender file, deleteing one of them seems to solve it.
I can provide the blendfile and html if needed but I think it is easy to recreate with a default scene, just add a new scene to the same file.
https://plus.google.com/+DuarteFarrajotaRamos
09 December 2014 15:27 #689
Hello Duarte,

There is definitely a problem exists. Several scenes are causing it. It is being reproduced easily as you have said.
It will be fixed in the next release. Now it's really better to avoid using several scenes.

Thanks for pointing out a bug.
Blend4Web developer
09 December 2014 15:39 #690
Thank you very much for the quick reply, glad to know it'll be fixed, luckily it is easy to avoid for now.
Also not sure but it's probably related too, there seemed to an associated issue with defining an orbiting point for the camera target, but it's probably another manifestation of the same bug.

Thanks again

https://plus.google.com/+DuarteFarrajotaRamos
 
Please register or log in to leave a reply.