Forum

Vertex Normal Problems

31 March 2016 19:04 #8617
Hey Blend4Web Team

First of all i have to say, your Blender addon is amazing.
I was looking a long time for a probber solution to rotate the vertex normals and with your script its so easy.
One thing i couldn't manage is to use it with a mirror modifier. Is it possible to mirror the changed vertex normals?

In detail i tried to get a low poly hard-surface object with one bevel to smooth the edge and i faced out the normals. (like in you youtube video) Everything worked fine on the original side but on the mirrored site the normals didn't rotate. I tried everything but i was not able to manage that problem. The only way is to do it manualy but this is troublesome :(

Can you help me? I attached an image for a clear explanation :) the right side is the original one, the left side the applyed mirror modifier with broken normals

Thanks
Chris


Portfolio: www.poleegon.com
01 April 2016 10:50 #8631
Hello and welcome to our forums! :)

Unfortunately we couldn't reproduce the issue. Can you please record a screencast and/or send us the ..blend file?
3D Generalist, contests administrator,
Blend4Web team.
art blog: http://contret-art.tumblr.com/
01 April 2016 21:14 #8650
This blend has all my questions :)

thank you for your quick help
02 April 2016 01:35 #8655
Hi!
We have already met this issue and reached the bug report. This is known TODO. Сurrently edited normals do not work well with modifiers.
Alexander (Blend4Web Team)
02 April 2016 15:18 #8659
ah ok … if this works in future i will be very happy

great software :)
 
Please register or log in to leave a reply.