Forum

Camera "eye mode" but also move camera

30 May 2016 16:25 #9784
Hello,
I have a problem. I use the blend4web node system and I want to use "MoveCamera" node, but I also need to have the camera in "eye mode". Both together do not work.
I need to move the camera to different places in a room, but at this places the user is just allowed to look arround (360 degrees) but not to move camera.
Any ideaa?
30 May 2016 16:34 #9785
I have a problem. I use the blend4web node system and I want to use "MoveCamera" node, but I also need to have the camera in "eye mode". Both together do not work.
You can use Move Object node instead of Move Camera node to move it - it's more easier, but Move Camera node must work fine, you need to select Look At point even for eye camera type.

I need to move the camera to different places in a room, but at this places the user is just allowed to look arround (360 degrees) but not to move camera.
It's possible only using API with programm code, in future we will support it and it's in our TODO list to make Change Camera Node or something like that and add camera move limits to eye camera.
Blend4web and that kind of thing.
30 May 2016 17:16 #9786
…., you need to select Look At point even for eye camera type.

What do you mean? How or where should I select Look at?
30 May 2016 17:24 #9787

What do you mean? How or where should I select Look at?
In Move Camera node preferences.
Blend4web and that kind of thing.
30 May 2016 17:30 #9788
Now, I get what you mean. Sorry, looks like I did not read propper first time.

I was already setting "look at", but I was not able to move the camera after jump with "Move Camera".
When I use "Move to" camera is pointing down after jump.
30 May 2016 17:37 #9791

I was already setting "look at", but I was not able to move the camera after jump with "Move Camera".
Can you share with us an example of your scene, camera must move freely after jumping.
Blend4web and that kind of thing.
30 May 2016 17:38 #9792
Ok, it is working now somehow, but not always.
If I don´t move the camera (look arround) it is ok, but if I look arround the "Move Camera" Node is not working anymore.
30 May 2016 17:39 #9793
Can I send the file to a mail adress?
30 May 2016 17:49 #9794

If I don´t move the camera (look arround) it is ok, but if I look arround the "Move Camera" Node is not working anymore.
Ok, I understand. It's a common problem. You need to do this:

After you move camera a little you just make a lick on the scrin so the Switch Selcet node thinks that you miss and do nothing, so you need to cyrcle this node on itself to explane to it that it need again to wait for click on object.
Blend4web and that kind of thing.
30 May 2016 17:50 #9795

Can I send the file to a mail adress?
Sorry, but support via email only for PRO users.
Blend4web and that kind of thing.
 
Please register or log in to leave a reply.