Forum

15.01 Web Viewer Bugs

29 January 2015 20:43 #1224
It seems that sometimes the 3D navigation locks up; this can be produced by hitting the "rotation" button: followed by hitting the Pause button next to it. It sometimes has different responses; say if you hit ther rotation button twice: it might work. But I think we should all assume that users on the World Wild Web, will be overly anxious to press every button just for the sake of trying it out.

Also, in Safari it seems that the Fullscreen button has no effect. It does seem to work in Firefox however.
29 January 2015 20:48 #1225
Looking at this a bit further; It seems that sometimes hitting the Play button after hitting pause can reinstate the 3D navigation. Though sometimes it seems to not return; and also hitting the rotate button multiple times does not restart the scene rotating. I am not sure if this was the way it was designed or if this is just a new glitch.
29 January 2015 21:16 #1226
The more I look at this the more I think that it may be working as designed; but still perhaps confusing to users.

Here is a proposed solution that I feel would make it less confusing:

When someone presses the "Pause" button and it then shows the "Play" icon; the "Play" icon should be a strobing icon such as grey slowly flashing on and off; to show that the button is actively "Locked".

The Turntable or "Rotate" button seems to work or not work depending on whether the Play/Pause button has been pressed while the Scene was in Rotation mode. Perhaps anytime the scene has been Paused; and someone presses the "Rotate" button again, it should start rotating and automatically switch the Play/pause button as well.

-Also- If someone hits the Pause button either one of two things should happen:

1) the buttons should stay pinned open (with the flashing play/pause icon),

-or-

2) the buttons collapse; but the single button in the lower right hand corner changes to the Flashing "play/pause" button until pushed. Which then restores the normal "settings" icon.
30 January 2015 10:53 #1232
Thanks for suggestions. We discussed it all and decided to make some changes to the interface. Probably without a color indication but with a more expected behavior.
Blend4Web developer
19 February 2015 17:07 #1455

The Turntable or "Rotate" button seems to work or not work depending on whether the Play/Pause button has been pressed while the Scene was in Rotation mode. Perhaps anytime the scene has been Paused; and someone presses the "Rotate" button again, it should start rotating and automatically switch the Play/pause button as well.

Done for the upcoming 15.02 release.
Development Lead | Twitter
 
Please register or log in to leave a reply.