Forum

Uncaught TypeError: Cannot read property 'length' of undefined

12 December 2016 01:50
After some minor changes to a scene, it will now only load to 45%, and the error below seems to be the cause:

Uncaught TypeError: Cannot read property 'length' of undefined
at submesh_list_join_prepare_dest (geometry.js:930)
at Object.submesh_list_join (geometry.js:802)
at merge_metabatches (batch.js:1453)
at Object.exports.generate_main_batches (batch.js:463)
at Object.process_scenes [as cb_before] (data.js:1168)
at process_stage (loader.js:439)
at process_stages_queue (loader.js:327)
at Object.exports.update_scheduler (loader.js:275)
at Object.exports.update (data.js:110)
at loop (main.js:427)

My apologies if this is the wrong place to report it - i don't see how what i changed caused it. I was having problems using group instances to position things, so i got rid of them and replaced them with linked duplicates, and then this started happening. I have been refining the scene and it was displaying well before this.

The test is on our Github website - you have to scroll down a little to the second iframe. The errors reported in the console are a bit different, the above was generated by the Fast Preview tool. The files are also attached.

Thanks for your help.
12 December 2016 14:53
Hello!

Thanks for the feedback. I've found the issue but I couldn't reproduce it. Could you send me a simple blend-file, which demonstrates the wrong behavior?
For the workaround you can add the UV layer to the Sphere.000 mesh

Thanks
Blend4Web developer
 
Please register or log in to leave a reply.