No Shadows on Mobile

22 December 2016 20:12

New here, Blend4web is absolutely amazing, however I found lately that no matter what I do, there are no dynamic shadows in the mobile (android) chrome browser. Is this a known limitation? Or by design? Is there any way to hack this on?

Tested it on a Galaxy S5 (with a slightly outdated Android) on latest Chrome, and other android devices - including Google Tango.
23 December 2016 03:58
You can maybe try forcing the setting on or off.

canvas_container_id: "main_canvas_container",
callback: init_cb,
shadows: true,
physics_enabled: true,
show_fps: true,
alpha: false,
autoresize: true,

this function will give you a pop up to tell you what has been detected as your browser.
function detect_mobile() {
if( navigator.userAgent.match(/Android/i)
|| navigator.userAgent.match(/webOS/i)
|| navigator.userAgent.match(/iPhone/i)
|| navigator.userAgent.match(/iPad/i)
|| navigator.userAgent.match(/iPod/i)
|| navigator.userAgent.match(/BlackBerry/i)
|| navigator.userAgent.match(/Windows Phone/i)) {
return true;
} else {
return false;

The b4w webplayer lets you toggle between different quality settings.
might help you debug it ;)

I found that detect mobile worked against me, it was detecting mobile and downgrading my settings even though I was on a phone that could run 60FPS on high quality.
23 December 2016 11:41

We use depth texture for shadow casting. I think, your device doesn't support it. Please, visit and check it:

Please register or log in to leave a reply.