Forum

Bake armature animation and export problem

19 January 2017 17:08
Hi,
i have a problem with export bake armature animation.
HTML file doesn't start animation.

What is the problem?

I attached file blend.

Thanks.
24 January 2017 17:27
On your mesh object you have "Apply Modifiers" option on.

In is in Object settings under Export Options.
Turn it off and and everything will start working

It applies "Armature" modifier, so we don't see animation.
3D Generalist, contests administrator,
Blend4Web team.
art blog: http://contret-art.tumblr.com/
25 January 2017 12:19
Ok, perfect!
Thanks!

Another question:
i used bbones with segments for each bone in Blender but Blend4Web doesn't support them.
However when i apply modifiers and exported html in a frame (in example at frame 20 of deform armature animation) the object is deformed correctly (but i don't see animation),

while if i don't apply modifiers and exported in html the object is deformed as if the bone hasn't segment subdivision.

Why?

I attached two images
apply modifiers option activated


apply modifiers option disable
25 January 2017 12:41
Blend4Web doesn't support b-bones 
You can just subdivide them using IK and/or curves. After all these operations with constraints the animation must be baked.

More about animation

With modifiers applied the mesh itself is deformed, and this deformation is exported to the engine. Thus working b-bone shapes with modifiers applied

upd:
In future we will support b-bones, plus bone constrains as well
3D Generalist, contests administrator,
Blend4Web team.
art blog: http://contret-art.tumblr.com/
25 January 2017 13:02
Ok, thanks a lot!
 
Please register or log in to leave a reply.