Addon is not compatible with "Windows x64" platform.

21 April 2015 18:36
We have been chasing the issue for a day and this is what we found. The plug-in is dependent on

Microsoft Visual C++ 2010 SP1 Redistributable Package (x64)

Every system where it has failed show did not have this, when we installed it bingo all problems went away.

I we find something else I'll report back.

If this fixes the issue of 'Addon is not compatible with "windows x64" platform' will you guys install the MS Runtime Library?
21 April 2015 23:24
Thanks for the info.

We will check the issue on some "clean" machine (actually there is not much Windows computers here in Blend4Web ).

will you guys install the MS Runtime Library?

As I understand from here, the GPL license forbids to provide MS runtimes inside programs. I think we should find some other solution here.
22 April 2015 19:20
We've managed to build addon modules with Microsoft Visual C++ 2013. I think the problem should be fixed now, check our new release coming next week.
29 December 2015 19:46
Hi! Dear Devs. seems probem is still there.

Win7 64bit sp1 & vc2008(x86&x64) & vc2010(x86&x64) & vc2013(x86&x64) & vc2015(x86&x64)
& all access right
& unzip blender2.76 on desktop.

& test add-on 15.11 15.12

Thanks for you Great works!
30 December 2015 17:50
We can't reproduce this behavior, so I've added a tracing code to 15.12 addon. It will not fix the issue, but it just generates useful information. Run Blender in cmd with installed addon and then show me the blender console output. Also in the current directory you will see a new one, named "cover". Attach it here, please.
Alexander (Blend4Web Team)
04 January 2016 00:10
I can't believe it's happening again…
15 October 2016 00:12
Hi there!
At our Cineca virtual school we encountered that issue too with a student. The PC has a windows 10 x64 os.
We tried to fix the permissions and the visual studio stuff but everything is ok, after that we saw the blender 32bit recommendation and tried it with no success…
In the end what worked is to open blender with administration privilege

Hope it helps to investigate!

17 October 2016 16:02
Hi Daniele,

Thanks for reporting this. We'll take look at the issue.
The Founder | Twitter | Facebook | Linkedin
05 January 2018 20:20

Same problem for me with the 17.12.0 add-on version and a fresh blender 2.79.1 daily build (blender-2.79-95d83b9-win64).
I have the error popup "Addon is not compatible with "Windows x64" platform, even if I start Blender with administrators privileges.
And this message appear in the blender console window :

Can't load Blend4Web binary module, the cause can be tmp directory, which doesn'
t allow execution. Try to change it in 'Blender User Preferences' ('Temp' field
on the 'File' tab.
B4W binary error: exception text: 'DLL load failed: Le module sp├®cifi├® est int
serving at port 6687

I'm running Blender on Windows 7 64bits.
09 January 2018 14:29
Never use non-release and non-official builds. We don't support them. Technically they could cause even corruption of your data. First try the 2.79 release.
Alexander (Blend4Web Team)
Please register or log in to leave a reply.