Forum

WebVR with the HTC Vive

24 May 2017 09:30
I have been experimenting with the Vive and the Blend4Web VR example project. Currently on SDK version 17.04.1. I have it working in both Chromium experimental build and Firefox Nightly.
I did not need to make any settings changes in Nightly. You can download it here:
https://webvr.rocks/firefox
For Chromium, you can get it here:
https://webvr.rocks/chromium
I did make some changes in Chromium as detailed here:
https://webvr.info/get-chrome/

With Chromium I usually end up with the regular monitor flashing the scene while the experience is running. It looks fine in VR but flashes at a fast rate on the monitor, not sure why. I have occasionally had it show a normal dual image. On Firefox Nightly, it just showed a blank screen on the regular monitor while the VR headset was running. Makes it hard to record video.
The sound is a little buggy on all my Steam VR games. I had the sound working for a while with Chromium in the WebVR demo. The blocks make a 'plunk' sound when thy land. Then it stopped working and did not work with Firefox. I will keep playing around with it and see what I can learn.

I was wondering why the square blocks in the Blender scene were on a separate layer from the balls and cones. is there a physics reason for that?
25 May 2017 12:08
I was wondering why the square blocks in the Blender scene were on a separate layer from the balls and cones. is there a physics reason for that?

No, no reason at all, it was just more convenient to sort them that way
3D Generalist, contests administrator,
Blend4Web team.
art blog: http://contret-art.tumblr.com/
 
Please register or log in to leave a reply.