Animation problem on Android Chrome browser

06 July 2017 12:29
another question on mobile devices debug:

I created a model interactive with simply keyframe animations activated in logic editor (play timeline or play Animation node).
Everything works well (Chrome, Safari, Firefox on iPad, Chrome, Safari, Firefox on PC, Firefox on Android) apart on Android Chrome browser (on my smartphone): the animations doesn't start…

I checked it with developer function of Chrome browser and there are only two warnings:

Where is the problem?

I attached only file html with model!

06 July 2017 13:24
It worked on my Android S7 Edge with Chrome. Animations 1 and 2 worked with sound (very nice project).
I am wondering about your button size. It took me a couple of times to hit the button. Can you run a test to make sure the button is activating? For example, add a play sound node after the Switch Select node to make sure the button is getting hit.
Another test you could do, is let the animation run automatically. You can temporarily add an Entry Point node that leads to your animation node. This way you can find out if it is the button or the animation that is the problem.
06 July 2017 15:56
Thanks for reply!

You talk of button for to change colors or all buttons (for animations and for change color material)…and you mean that buttons are too small? I have a huawei p9….i'll try your tests….

06 July 2017 19:43

I added a Entry Point node for run animation automatically and the animation starts correctly….

Every now and then chrome gives a mistake to the webgl library…Then I reload the file without errors!

i don't understand….
07 July 2017 01:20
How did you make those little spherical animations? Is it animated texture? I wonder if you are using some sort of texture or media that is not formatted correctly. Have you tried using the Convert Media option in your Project Manager? This optimizes sound, image texture and more.
07 July 2017 11:54
Yes, is an animated texture (a time node animates uv coordinates and i used a simply png image).

I didn't use Convert Media…I'll try!

But it's strange that the animations function in all browsers (also on iphone) apart on Chrome of my smartphone….
07 July 2017 13:19
I thought your spherical animation was very cool.
Keep in mind, it is an amazing feat of engineering to get software this complicated to work on a multitude of browsers. That it works at all is a miracle LOL.
If you remove pieces and parts of your app one at a time, you will probably find out which part caused the problem. I suspect it is some form of media like a texture or maybe even one of your sounds. Convert Media is intended to convert whatever file you have into multiple other formats to fit all browsers.
07 July 2017 13:49
yet!…it'a miracle…

Thanks a lot for support….
07 July 2017 14:05
A last question a little off topic:

In fast preview the SSAO parameters are disable though i cheched SSAO option on render tab and shadowobject parameters.

Is there a reason?
07 July 2017 14:30
Do you have any objects set to cast or receive shadows?
I think you need at least one object set to cast or receive shadows in the Object Menu.
Please register or log in to leave a reply.