JDK Compile problems on OSX

20 August 2017 14:21
Hey all, I posted a couple of weeks ago with this error, but have subsequently tried lots of things to correct it, with no success.

I began by installing everything on my other Mac, including:

Java (it didn't have ANY Java RT on it, it's a new computer)

I also installed the latest JDK.

The problem still exists… Here's the Java console error:

ReferenceError: Can't find variable: b4w
Global Code myProject.min.js:8:474

Initially, the script was also looking for the 'deploy' directory on my server too, which seems odd.

I'm running El Capitan 10:11:6

And here's my Java setup.

java version "1.8.0_144"
Java(TM) SE Runtime Environment (build 1.8.0_144-b01)
Java HotSpot(TM) 64-Bit Server VM (build 25.144-b01, mixed mode)

This problem is now a couple of weeks old and I've not been able to solve it, which is why it's now in the Bugs section.

Note: My minified build-project can be downloaded here, if anyone would like to take a look at it:

Any help would be appreciated, thanks.

20 August 2017 17:18
Have you tried changing the path variable as outlined in this post?
I have had lot of trouble with Mac and that finally solved it for me. The video linked in that thread goes into detail.
20 August 2017 17:47
Thank you, I'll explore this.

20 August 2017 19:44
OK, so I didn't have a bash file, so I created one using Nano and included the rule you mentioned above.

Unfortunately, the error remains the same. One interesting observation I've made is this:

The error is on this line:
b4w.register("OFFICE_DEMO_main", function(e, f)

(OFFICE_DEMO is the name of my project)

The '_main' is NOT part of my project name and I'm not sure where it comes from. If I amend the name in a text editor and reave, the app runs in the browser with no errors but the screen is completely black.

21 August 2017 07:51
I didn't have a bash file
Did you enable hidden files on your Mac? You should then be able to see the .bash_profile in your Home directory.
If you strictly followed the directions in this video, by installing the SDK from the same location and it still doesn't work then I can only guess that you have a unique issue on your computer that is interfering. Have you tried it on an alternate computer?
Please register or log in to leave a reply.