Forum

Planetarium Solar System OSX Firefox

29 March 2015 03:19 #1861
Hello,

The Planetarium Solar System is really awesome.

In Firefox it works fine in version 34.0 on Linux but does not work perfectly in Firefox 36.0.4 on OSX where the background galaxy is missing. I am not sure what is causing this bug. Perhaps it is a bug in Firefox.

Will you give us some hints about how you made the Planetarium? I really want to get a Planetarium running in my own App.


Thanks,

Drew
30 March 2015 00:41 #1865
Will you give us some hints about how you made the Planetarium? I really want to get a Planetarium running in my own App

Hi. This is a new feature Release Notes v15.03 (New tool for adding annotations to 3D objects.)
Manager and 3D Generalist at Blend4Web
No pain, no gain.
mikhail@blend4web.com
30 March 2015 10:49 #1874
In Firefox it works fine in version 34.0 on Linux but does not work perfectly in Firefox 36.0.4 on OSX where the background galaxy is missing. I am not sure what is causing this bug. Perhaps it is a bug in Firefox.

Hi,

There are numerous bugreports from Firefox users on Mozilla website. For some reason, it reduces the actual texture size limit comparing to other browsers, and big textures are not allowed to be drawn on Mac. So, there is nothing we can do right now. Need to wait for fix from Mozilla.
Blend4Web developer
30 March 2015 22:33 #1892
Wow.

It is a major bug in Firefox. Thanks for that information.

Hopefully Mozilla will fix it.
31 March 2015 12:39 #1899
You can see the info about this bug here, and probably make a report, because Mozilla haven't confirmed it yet.

I've dived into this issue deeper and found that this is (probably - "was") a bug in Intel GPU drivers for Mac. Such limitations were previously in Chrome as well, but they were removed. So, I assume, this can be fixed by Mozilla by simply removing the limitation code which looks like this for now:
#ifdef XP_MACOSX
if (mWorkAroundDriverBugs) {
if (mVendor == GLVendor::Intel) {
***Reduce the max texture size***
Blend4Web developer
31 March 2015 23:19 #1914
I have posted on this bug report and have attached a screenshot of the problem. Apparently this is to do with a security issue on OS X.
31 March 2015 23:19 #1915
Oops sorry for the double post.
01 April 2015 01:16 #1918

Ответ на сообщение пользователя Evgeny Rodygin
You can see the info about this bug here, and probably make a report, because Mozilla haven't confirmed it yet.

I've dived into this issue deeper and found that this is (probably - "was") a bug in Intel GPU drivers for Mac. Such limitations were previously in Chrome as well, but they were removed. So, I assume, this can be fixed by Mozilla by simply removing the limitation code which looks like this for now:
#ifdef XP_MACOSX
if (mWorkAroundDriverBugs) {
if (mVendor == GLVendor::Intel) {
***Reduce the max texture size***

I was advised to start another bug report because this particular issue affects intel on OS X. Here is the bug report.
01 April 2015 09:50 #1919
Thanks for filing the bug report!
Development Lead | Twitter
 
Please register or log in to leave a reply.