Forum

Problems with Firefox?

05 February 2018 17:45
Hello everybody!

First of all, thank you for developing a great a framework, that makes a lot of cool stuff possible.

I seem to have a problem displaying WebGL in Firefox and Opera for the last couple of days now; either the link to the troubleshooting-page appears - or the canvas stays blank altogether. I've been able to reproduce this on different computers. My suspicion is that there is some problem with changes made in response to Spectre/ Meltdown; apparently they did something to the timing of java script being executed in the chromium engine….

I wonder if any of you have experienced similar problems, or whether it's after all only a number of local issues on some machines (or even on layer 8?!)
If there is more of a general issue, I wonder what can be done to maximize the compatibility of blend4web files.

Any thoughts, anyone? I'm thankful for any advice.

Greetings and Thanks in advance
06 February 2018 12:52
Hello! And welcome to our forum!

What are the settings of you computers? GPU, CPU, Operating system? We haven't encountered any systematic problems. Sometime such issues could relate to the GPU driver updates.
Alexander (Blend4Web Team)
twitter
07 February 2018 19:21
Hi, Alexander!

Thanks a lot for your answer.

In both cases it's Windows 10, 64bit - one computer has a CDUA 1000M graphics card in it which apparently has received a new driver. Being old and very specific, that card is prone to cause driver problems sooner or later.

The other computer has intel 5000 CPU graphics. Can't see much of a pattern there.

Interestingly or ironically, of all browsers, Edge is the one that it works with in both cases.

I'll just file the story under "odd things computers do that we won't understand" and tell the recipient to use Edge and wait for the next update. :-)
29 September 2018 13:17
can cause problems with Firefox. Periodically, you should scan your system for viruses, spyware, or other malware. For more information, see Troubleshoot Firefox issues caused by malware, and if rather than not get solve this problem try Mozilla support for the help.
 
Please register or log in to leave a reply.