Forum

No Shadow in the Scene - Table of Centents

24 July 2015 11:23 #3171
Hello, in the Table of Contents I read on the subject shadow:

1. Enable the Blend4Web > Shadows Cast checkbox under the Object tab for the objects which cast shadows.
This is OK!

2. Enable the Blend4Web > Shadows Receive checkbox under the Object tab for the objects which receive shadows.
This is OK!

3. Make sure that the Blend4Web > Render shadows checkbox is enabled in the Scene tab.
This I cant find! I have no entry under Scene to put shadows on or off.

My Result: My Scene indeed has a dark side of the cube, but where the shadows should be, everything is normal, without any shadow on the landscape (Plane). I use Blender internal Render (Blender Render - Blender 2.74). What am I missing. Does anyone have instructions for me?

thx
zero

24 July 2015 11:47 #3172
Hello and welcome to the forum

Try the latest Blender(2.75a) with the latest B4W (15.07)!

And tell us please what type of device and browser are you using
3D Generalist, contests administrator,
Blend4Web team.
art blog: http://contret-art.tumblr.com/
24 July 2015 12:20 #3173
Hello Pavel, thx for the welcome.

I test it on Firefox and Chrome. Both browsers are up to date.
And now I test it with Blender 2.75a – 64Bit
My System is Win7 – 64Bit

I send you 5 Screenshots for Documentation. In this pictures you can see my settings (yellow Borders). I miss in Blender 2.75 the Scene-> Shadow Adjustment.

Edit: I saved the Scene as HTML







Thx for your Help
zero
24 July 2015 14:01 #3177
Yeah, the documentation is a bit outdated. In the new interface in 15.06 some things have been changed. So, for setting up the scene with the shadows you just need to do this:
https://youtu.be/7hutGrqgqig


Also try opening this shadows.html and tell me if you won't see shadows here, too

3D Generalist, contests administrator,
Blend4Web team.
art blog: http://contret-art.tumblr.com/
24 July 2015 15:28 #3179
Dear Pavel, thanks for the shadow.html. I was able to see that it works.

I watched the video clip and also done the same. Now it works! I had worked only the cube and the light. Given the Cube "Cast" and "Receive", the Plain nothing. That was the mistake.

Now I understand the procedure!

Thank you so much for your help and this great feature!



Nice greetings.
zero
24 July 2015 16:11 #3182
You're welcome!
I'm glad everything works fine now
3D Generalist, contests administrator,
Blend4Web team.
art blog: http://contret-art.tumblr.com/
07 August 2015 05:45 #3344
I still don't get it :( the shadow.html that you gave @pavel does not shows shadow to me . I followed the video tutorial that you gave but still it does't work . The blender that I used is v2.75


07 August 2015 11:07 #3347

I still don't get it :( the shadow.html that you gave @pavel does not shows shadow to me . I followed the video tutorial that you gave but still it does't work . The blender that I used is v2.75

Hello and welcome to our forum.
Can you write in your browser address line the next:
about:gpu
and:
webglreport.com

And send us the info from them
Blend4Web developer
28 June 2016 12:34 #10263
Hi I had the same problem as aldine_jade17, so I decided to change from chrome to edge and it worked perfectly. I've still attached the webgl report though (from chrome).
28 June 2016 12:52 #10265
Hi and welcome to the Blend4Web forums!
Hi I had the same problem as aldine_jade17, so I decided to change from chrome to edge and it worked perfectly. I've still attached the webgl report though (from chrome).
Looks like Chrome doesn't like your hardware and decided not to expose the depth texture extension.
Development Lead | Twitter
 
Please register or log in to leave a reply.