Forum

Logic nodes JSON HTML

27 January 2016 12:42 #6834
the second one. And restart blender.
27 January 2016 12:47 #6837
Do you choose the path to the SDK directory or to blender_scripts folder?
Now, to install SDK, you just need to specify the path to SDK in the File->Scripts section of the User Preferences panel.
Blend4Web Team - developer
27 January 2016 12:48 #6838
Ok! i reboot the i mac and now is ok. but..
when i try to export i receive this message:
..
in a new, very simple, blender project the export is right.
In my project sanpierota03_b4w there is an error.
what do you suggest?


27 January 2016 12:54 #6841
Sorry for that!
It really looks like a bug.
We are checking this issue right now!
Blend4Web Team - developer
27 January 2016 14:49 #6846
In my project sanpierota03_b4w there is an error.
what do you suggest?
Hi, we'll fix this bug in the final release. Apparently it's caused by an empty material slot, attached to some object. It should show the appropriate error message instead of crash during the export. Anyway, this empty slot should be deleted to make a faultless export.
Blend4Web Team
27 January 2016 17:24 #6857

In my project sanpierota03_b4w there is an error.
what do you suggest
Distributions were updated.
You can try again. Error shouldn't occure
Blend4Web Team - developer
27 January 2016 18:07 #6867
I tried.
you know a way to find this item? I can not find. I erased the textures and I changed. I have 2 texture and 3 materials.
There is an anomaly between the number of objects and the material. The boat has the number of objects and materials that match. The text consists of 28 objects repeated 2 times. total 56 items. Blender indicates that there are 61 objects using that material. 5 too. How do I find them? Isn't in the layers.

i re update 16.01…. i install the add on in a second.perfect! but only a problem: after close and re open blender can't change in b4w:

27 January 2016 18:54 #6869
Hello.

i re update 16.01…. i install the add on in a second.perfect! but only a problem: after close and re open blender can't change in b4w

Could you open Blender from the terminal and send us info from there, please?
Blend4Web developer
27 January 2016 19:04 #6870
you know a way to find this item?
It's the "cinturini.t.001" object. It's currently difficult to find, because it's a FONT.

Usually you can see an export error dialogue message like this:

It refers to a specific mesh, which (and related objects) can be found in Blender. But it's not accurate for FONT objects, because they go through a FONT->MESH conversion during the export and obtain a new generated mesh, which is specified in the message. But meshes like this are removed at the export end, because they aren't needed anymore and we don't want to produce redundant datablocks.

We will make a more detailed description for such errors in future.

Blender indicates that there are 61 objects using that material.

It's 55 for me, 56 minus one for cinturini.t.001:
Blend4Web Team
27 January 2016 19:32 #6872
Roman i did it
from terminal:
imac-di-arianna:~ ary$ /Applications/blender2.76a/blender.app/Contents/MacOS/blender
Read new prefs: /Users/ary/Library/Application Support/Blender/2.76/config/userpref.blend
found bundled python: /Applications/blender2.76a/blender.app/Contents/MacOS/../Resources/2.76/python
Traceback (most recent call last):
File "/Applications/blender2.76a/blender.app/Contents/MacOS/../Resources/2.76/scripts/modules/addon_utils.py", line 324, in enable
mod = __import__(module_name)
File "/Users/ary/Library/Application Support/Blender/2.76/scripts/addons/blend4web-2/__init__.py", line 76, in <module>
exec(load_module_script.format(m))
File "<string>", line 7, in <module>
File "/Users/ary/Library/Application Support/Blender/2.76/scripts/addons/blend4web-2/init_validation.py", line 21, in <module>
import blend4web
ImportError: No module named 'blend4web'





 
Please register or log in to leave a reply.