Forum

Node Change Color

16 February 2016 11:19
Hi

I just discovered your framework and i can say it's good.
As i'm trying to understand the logic, i make a simple scene and i want to change cube color via node.
I have RGB value that i want for the cube.

Can't make it work, color are rendered but color is wrong
Maybe light problem???

Thanks, sorry for my low level english

Result

Node



m_objets.set_nodemat_rgb("cube", ["Material","monRGB"], couleur1,couleur2,couleur3);
16 February 2016 12:12
Example if put the Hexa color on the cube on the right, you can see the difference.
Thanks

16 February 2016 12:22
Hello and welcome to the forum.

Can't make it work, color are rendered but color is wrong

I've checked it.
My .blend-file settings:


Here's test in browser:


Please, check couleur1,couleur2,couleur3 values. It should be > 0 and < 1
16 February 2016 16:35
sorry i will explain me better.
I set a cube in blender with a diffuse color an another with a node color.
When i set the same color on the node color, the render is different

I'm doing something wrong… I checked diffuse entisity etc…. Everything the same…


16 February 2016 17:13

sorry i will explain me better.
I set a cube in blender with a diffuse color an another with a node color.
When i set the same color on the node color, the render is different

I'm doing something wrong… I checked diffuse entisity etc…. Everything the same…
Can you attache your file with example?
Blend4web and that kind of thing.
16 February 2016 17:14
i finally found, i don't know if it's a bug, i have to put the DiffuseInt of the material inside the node to 0.5 instead of 0.8
16 February 2016 17:27

i finally found, i don't know if it's a bug, i have to put the DiffuseInt of the material inside the node to 0.5 instead of 0.8
It's can't be a bug I think, I think it's a differece of setup between node and simple material. So can you attach an axample, just to confirm my thoughts?
Blend4web and that kind of thing.
17 February 2016 10:13
i create a new project and can't reproduce the issue.
17 February 2016 14:20
i create a new project and can't reproduce the issue.
Glad it worked for you! An example Blender file demonstrating that strange issue would be appreciated though.
The Founder | Twitter
18 February 2016 17:29
I finally reproduce the issue
.blend attached

I thnink there's something i'm doing wrongly
 
Please register or log in to leave a reply.